Plugin error from fragment-insertion - CalledProcessError - run-sepp.sh - non-zero exit status 1

picrust
sepp
fragment-insertion
queued

(Jonathan Gaiero) #1

Hello,

I am trying to work on Picrust 2 via the QIIME2 plugin, but I am stuck on the first step which uses the plugin q2-fragment insertion.
I have looked through the forums but cannot not seem to find a definitive answer. I was hoping someone could help me out!

Disclaimer: I’m using QIIME2-2018.8, running via Ubuntu for Windows10. We successfully used QIIME2-2018.6 using this method. But we wanted to work with picrust2 and there was also an update to QIIME2 so it happened all together - hopefully not confounding the issues…

I followed the picrust2 installation protocol as outlined here:
https://library.qiime2.org/plugins/q2-picrust2/13/

and for q2-fragment-insertion here:

Everything seemed to install correctly, but I am getting errors right from the start with the tutorials (using fragment-insertion). I thought that the reference alignment and phylogeny files might have been an issue so I also tried the default settings as outlined in the fragment-insertion tutorial. But still the same errors.
I have tried my own rep-seqs.qza, mammal_seqs.qza (from picrust2 tutorial), and the sequences from the dada2 moving pictures tutorial. Same errors.

Error log states
“CalledProcessError: Command ‘[‘run-sepp.sh’, ‘/tmp/qiime2-archive-d0fhf34c/38a5d748-739e-44d1-b547-a35c0c8b8f29/data/dna-sequences.fasta’, ‘q2-fragment-insertion’, ‘-x’, ‘1’, ‘-A’, ‘1000’, ‘-P’, ‘5000’]’ returned non-zero exit status 1”

I found a suggestion from Stefan Janssen (here) to run the following command on the moving pictures data:

qiime fragment-insertion sepp --i-representative-sequences rep-seqs-dada2.qza --o-tree i-tree.qza --o-placements insertion-placements.qza --p-debug --verbose 2> err.txt > out.txt

  • Errors again
  • see attached files

Version number:
I ran the command as outlined here to get the version number

conda list | grep frag

Results:
fragment-insertion 4.3.5 py35_0 biocore
q2-fragment-insertion 2018.6.17 py35_1 biocore

Any help would be greatly appreciated. Thank you!

Jonathan

err.txt (1.6 KB)
out.txt (2.6 MB)


Error in qiime fragment-insertion sepp
(Nicholas Bokulich) #3

(Antonio Gonzalez Pena) #4

Hello @Jonathan_Gaiero,

To be honest, I have never seen that error, however, I have 2 theories:

  1. do you have enough memory? I would say at least 10G for the default tree
  2. are these 16S sequences?

Best,


(Antonio Gonzalez Pena) #5

(Jonathan Gaiero) #6

Hi @antgonza,

Thanks for the quick reply!

Darn, I was hoping the error wasn’t unique!

To answer your questions,

  1. Our system has 128 GB of RAM
  2. Yes, 16S sequences… from our own sequencing, from the picrust2 tutorial data, and from the qiime2 tutorial (moving pictures)

Regards,

Jon


(Nicholas Bokulich) #7

(Antonio Gonzalez Pena) #8

That makes 2 of us! :roll_eyes:

Anyway, could you post your rep-seqs-dada2.qza so I can take a closer look?

Thanks!


(Antonio Gonzalez Pena) #9

(Jonathan Gaiero) #10

This was one of the files I tried. https://docs.qiime2.org/2018.6/data/tutorials/moving-pictures/rep-seqs-dada2.qza

It was in a reply from Stefan Janssen to another user about a similar issue. But the rep seq file seemed to work fine for Stefan.

Thanks!


(Nicholas Bokulich) #11

(Antonio Gonzalez Pena) #12

Sorry for the delay. I have tested with that artifact and everything seems fine. Took ~20min:

07:24:42 Downloads$ qiime fragment-insertion sepp --i-representative-sequences rep-seqs-dada2.qza --o-tree rep-seqs-dada2-tree.qza --o-placements rep-seqs-dada2=placements.qza 
Saved Phylogeny[Rooted] to: rep-seqs-dada2-tree.qza
Saved Placements to: rep-seqs-dada2=placements.qza
07:47:13 Downloads$ 

Note that I used the latest version and this might be the source of the issue, you are using an older version. This is what I have:

$ conda list | grep frag
fragment-insertion        4.3.5                    py35_0    biocore
q2-fragment-insertion     2018.11.0                py35_0    qiime2-staging/label/r2018.11
$ pip freeze | grep frag
q2-fragment-insertion==2018.11.0

Would you mind updating your qiime2 to the latest version and see if you still have the same issue? If you still have it, could it be possible that you are running out of space in /tmp?

Hope this helps.


(Antonio Gonzalez Pena) #13

(Jonathan Gaiero) #14

No worries at all!
I will try updating soon, but when I installed the plugin for picrust2 that was the version of q2-fragment-insertion. Where can I get the latest version? Is it contained with the november qiime2 update?

Also, I have tried running the plugins in the latest qiime virtualbox (which uses version 2018.8) and it was successful using the tutorial files. I am currently testing our own sequencing data now.
To me this would indicate a problem related to the ubuntu shell on windows, but I have no idea why it would not work when qiime2 works fine…
Any thoughts on that?

I will update asap and let you know if that works. Thanks again!


(Antonio Gonzalez Pena) #15

That right, fragment insertion is now part of the qiime2 official release :fireworks:!!

Windows not playing nice: who knew?! Anyway, not really sure but it’s good to know and I’ll keep an eye open for this. BTW did you try your data in the VM, it will be interesting to figure out if it’s the install or your qza … but things are pointing to the install.


(Jonathan Gaiero) #16

Hi Antonio,

That is great news! I will try using the plugin on the new qiime2 release!

Haha. Yeah, I would like to work in native Linux… another day perhaps.

But in other news, I tested everything in the virtual box (qiime 2018.8 image), and its working fine! So it’s definitely something to do with Windows not playing nice with the Ubuntu shell. It would be excellent to find a solution and then everything would be working great on this setup with qiime.

I will let you know if the new qiime2 release helps solve the issue. Cheers!


(Lina Maria Martinez) #17

Hi Antonio,

I am getting the same error message running the command qiime fragment-insertion sepp. I checked the version and I have the lastest version but I am still getting this error message. I also have enough memory. Do you have any suggestion, please? thank you


(Lina Maria Martinez) #18

Dear all,

I just run the following command:
qiime fragment-insertion sepp \

–i-representative-sequences rep-seqs.qza
–o-tree insertion-tree.qza
–o-placements insertion-placements.qza

And I got the following error:

Plugin error from fragment-insertion:

Command ‘[‘run-sepp.sh’, ‘/home/ubuntu/linaqiimefiles/HealthyD/qiime2-archive-x43sce73/baad438c-4bca-4720-92b4-d43bb1ce65b6/data/dna-sequences.fasta’, ‘q2-fragment-insertion’, ‘-x’, ‘1’, ‘-A’, ‘1000’, ‘-P’, ‘5000’]’ returned non-zero exit status 1

Debug info has been saved to /home/ubuntu/linaqiimefiles/HealthyD/qiime2-q2cli-err-8oiauqwd.log

Could you tell what this error means, please? What can I do for making the command works? Thank you for all your suggestions


(Nicholas Bokulich) #19