error again

Hey there,
this issue is related/similar to the following but there was no follow up on the forum so I m afraid I have to bug you again:

I downloaded the latest qiime2 version (qiime2-2018.6) , activated qiime 2 environment and then installed fragment-insertionn using:

conda install -c q2-fragment-insertion
qiime dev refresh-cache

I ran into the issue described on the website with PackageNotfound error, which I also solved as described on the github page ( - thank you for that…

conda install -c anaconda -c defaults -c conda-forge -c bioconda -c q2-fragment-insertion
qiime dev refresh-cache

I tried running the following command on the rep-seqs output from dada2 in the moving pictures tutorial (ignore the joining of the dashes in the copied command):

qiime fragment-insertion sepp
–i-representative-sequences Downloads/rep-seqs.qza
–o-tree i-tree.qza
–o-placements insertion-placements.qza

and received the following error:

Plugin error from fragment-insertion:
Command ‘[‘’, ‘/var/folders/my/pq46r9ts5ns4b7xlvm1sk7m40000gn/T/qiime2-archive-ewpmr_fy/33e6372d-fab7-460b-89aa-b42b83262e03/data/dna-sequences.fasta’, ‘q2-fragment-insertion’, ‘-x’, ‘1’, ‘-A’, ‘1000’, ‘-P’, ‘5000’]’ returned non-zero exit status 1
Debug info has been saved to /var/folders/my/pq46r9ts5ns4b7xlvm1sk7m40000gn/T/qiime2-q2cli-err-wdv4qamf.log

less on the output file gives the following, which does not change after adding # to trap cleanup EXIT:

ages/q2cli/", line 274, in __call__
    results = action(**arguments)
  File "<decorator-gen-252>", line 2, in sepp
  File "/Users/rimachakaroun/anaconda/envs/qiime2-2018.6/lib/python3.5/site-packages/qiime2/sdk/", line 232, in bound_callable
    output_types, provenance)
  File "/Users/rimachakaroun/anaconda/envs/qiime2-2018.6/lib/python3.5/site-packages/qiime2/sdk/", line 367, in _callable_executor_
    output_views = self._callable(**view_args)
  File "/Users/rimachakaroun/anaconda/envs/qiime2-2018.6/lib/python3.5/site-packages/q2_fragment_insertion/", line 179, in sepp
    reference_alignment, reference_phylogeny, debug)
  File "/Users/rimachakaroun/anaconda/envs/qiime2-2018.6/lib/python3.5/site-packages/q2_fragment_insertion/", line 137, in _run, check=True, cwd=cwd)
  File "/Users/rimachakaroun/anaconda/envs/qiime2-2018.6/lib/python3.5/", line 398, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['', '/var/folders/my/pq46r9ts5ns4b7xlvm1sk7m40000gn/T/qiime2-archive-tbv78tgl/33e6372d-fab7-460b-89aa-b42b83262e03/data/dna-sequences.fasta', 'q2-fragment-insertion', '-x', '1', '-A', '1000', '-P', '5000']' returned non-zero exit status 1

thanks for the help in advance!

1 Like

This came up at STAMPS and I wasn’t able to figure out what was going on. @Stefan, any thoughts?

Hi Rima,

I just ran fragment-insertion on the freshly downloaded DADA2 rep-seqs and executed this command

qiime fragment-insertion sepp --i-representative-sequences rep-seqs-dada2.qza --o-tree i-tree.qza --o-placements insertion-placements.qza --p-debug --verbose 2> err.txt > out.txt

in a qiime2-2018.6 conda environment, which produces the artifacts without errors (placements are too large to upload). The file "err.txt" is empty (as expected) and the content of "out.txt" is attached.

i-tree.qza (2.3 MB)
out.txt (2.0 KB)

Can you copy and paste the result of conda list | grep frag?

just discovered the notification for this in my SPAM. sorry :S will get cracking and update this week.
Thanks for taking the time to reply and sorry again for not noticing earlier.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.