Invalid value for '--i-reads': Expected an artifact of at least type FeatureData[Sequence].

I'm trying to do taxonomic classification of my fastq files created with Amplicon. The naming of fastq files is ANK1_S1_L001_R1_001_fastq.gz and ANK1_S1_L001_R2_001_fastq.gz. I used the following code to convert my fastq.gz files to qza format.

qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path casava-18-paired-end-demultiplexed
--input-format CasavaOneEightSingleLanePerSampleDirFmt
--output-path demux-paired-end.qza

Then, when I finally run the following code after the other relevant steps, I get an error saying "Invalid value for '--i-reads': Expected an artifact of at least type FeatureData[Sequence]. An artifact of type SampleData[PairedEndSequencesWithQuality] was provided" . I can't find where I made a mistake. I really need help. Please can you help?

qiime feature-classifier classify-sklearn \
--i-classifier classifier.qza \
--i-reads demux-paired-end.qza \
--o-classification taxonomy.qza

Hi @elifi,
You will need to do quality control of sequences before you can classify them!

You will need to run dada2 to transform your sequences from SampleData[PairedEndSequencesWithQuality] to FeatureData[Sequence]. The Moving pictures tutorial should help for the workflow necessary for analyzing data.

Additionally if you are an audio learner, we have a youtube playlist:

I hope these resources help!

1 Like

Firstly thank you for your reply.
After qiime tools import command line, I used
qiime demux summarize
--i-data demux-paired-end.qza
--o-visualization demux-paired-end.gzv
The results are as follows.

Then I did the following to remove the sequencing adapters.
qiime cutadapt trim-paired
--i-demultiplexed-sequences demux-paired-end.qza
--o-trimmed-sequences trimmed_adapters.qza

Their results are

Then, I am trying to do qiime dada2 denoise-paired as you said, but I could not understand how to set the parameters. What is your suggestions based on these images?

Hi @elifi,

Selecting trimming settings is a highly selective process. It depends in part on your own experimental goals! So I suggest reading more about this in the documentation and see also our code of conduct related to doing for own work: Code of Conduct - QIIME 2 Forum. We are more then willing to help debug or help understand results but we can not select parameters for your analysis.

May of your tutorials cover this concept as well as a couple of our youtube videos. I would really recommend checking out our documentation to help you decide what sampling depth to use.

I hope this helps!

1 Like

First of all, thank you for your feedback. The parameters I set for the above QC plot are as follows.
qiime dada2 denoise-paired
--i-demultiplexed-seqs Sample1_Results/Trimming/Sample1_trimmed_adapters.qza
--p-trunc-len-f 290
--p-trunc-len-r 255
--p-trim-left-r 55
--p-n-threads 24
--o-representative-sequences Sample1_Results/Denoising/Sample1-rep-seqs.qza
--o-table Sample1_Results/Denoising/Sample1-table.qza
--o-denoising-stats Sample1_Results/Denoising/Sample1-stats.qza
First of all, since the quality for forward only drops around 290, I set my trunc-len-f parameter to 290. However, for reverse, the quality started to decrease around 190, but if I cut it from 190, it might be a lot of loss data. SO I set it to 255. Also, the quality started to decrease at the beginning of the reverse, so I set the trim-left-r parameter to 55. HOwever, I read somewhere a recmmendation not to trim paired-end data during this analysis. SO ı am not sure if I should trim the analysis or not. I am not sure if the above parameters are well adjusted according to qc results. Because when I changed these parameters, my taxonomy result also changed.

Hi @elifi,
Have you looked at your Sample1_Results/Denoising/Sample1-stats.qza file? This should give you a pretty good idea of how your sequences are passing dada2.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.