(1/1) Invalid value for '--i-reads': 'sequences.qza' is not a QIIME 2 Artifact (.qza)

I previously excuted the following command succeasfully for 3 samples:

qiime feature-classifier classify-sklearn --i-classifier gg-13-8-99-515-806-nb-classifier.qza --i-reads /home/temp/Desktop/sequences.qza --o-classification taxonomy.qza`

However now when i am excuting it for more samples i keep getting this error

(1/1) Invalid value for '--i-reads': 'sequences.qza' is not a QIIME 2 Artifact (.qza)

I have tried changing directory, still same error
I placed the file in the working directory, checked if the file is there by giving "ls" command. the sequence.qza file is there in the directory, still the error
i have checked the memory:

I have removed any similar name files from the directory. still no help

KIndly help

Hi @komal
Can you run qiime tools validate on that artifact and screenshot the output?

Hello, Please find below the out put.

(qiime2-2023.7) temp@temp-B365M-DS3H:~$ qiime tools validate sequences.qza
Result sequences.qza appears to be valid at level=max.

Thank you

@komal,
hmmm that is weird :thinking:

I believe this is sometimes caused by a issue in the QIIME2 installation. Could you remove your env and reinstall. After you have a fresh QIIME2 installation, try running this command again :point_down:

Hello, I just downloaded another classifier and it simply worked.Thank you for your help and time

qiime feature-classifier classify-sklearn
--i-classifier gg-13-8-99-nb-classifier.qza
--i-reads sequences.qza
--o-classification taxonomy.qza

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.