sequence quality control and feature table construction error on Nextseq 2000 data

Hello, I am running a research on fecal microbiome and we have 36 demuxed samples of 16s paired end sequences generated in Nextseq6000SP. While trying to run DADA2

  • I have searched for the problem on the forum
    -Qiime version 2022.2 installed using conda V

What is the exact command or commands you ran? Copy and paste please.

  • What is the exact error message? If you didn't run the command with the --verbose flag, please re-run and copy-and-paste the results.

Hello, we are conducting a fecal microbiome study, currently, we have 36 demultiplexed 16s paired-end samples generated in Nextseq200 P2 and analyzed in Qiime v. 2002.2 installed with conda. We have encountered an error while running dada2. Up until this point, we imported the data with the Fastq manifest format (PairedEndFastqManifestPhred33V2) and obtained a file of 62.7 gb. After demultiplexing the sequences we obtained a weird interactive quality plot.

And when running the sequence quality control and feature table construction with DADA2 we get the following error:

qiime dada2 denoise-paired
--i-demultiplexed-seqs paired-end-demux.qza
--p-trim-left-f 0
--p-trim-left-r 0
--p-trunc-len-f 150
--p-trunc-len-r 150
--o-table table.qza
--o-representative-sequences rep-seqs.qza
--o-denoising-stats denoising-stats.qza
--p-n-threads 8
--verbose

An error was encountered while running DADA2 in R (return code -9), please inspect stdout and stderr to learn more.

we have obtained this error while running the command with all the files, only 5 files, the R1 sequences and the R1 and R2 sequences. We are working in a 64 GB RAM computer.

Please see demux file attached:

demux.qzv (306.7 KB)

We have also tried running DEBLUR, attached you can find the file. We have tried to run the Deblur with different parameters and fewer samples, and still, the error persists.

Please see the file attached:

deblur.txt (348.9 KB)

Thank you in advance for your kind responses.

Carolina

Good morning Carolina,

Welcome to the forums! :qiime2:

The -9 exit code means that the process was 'killed' (stop, canceled) by the computer. This can happen when your computer runs out of memory.

While your computer has 64 GB of RAM, you also have 400 million reads! I wonder if that's using up all your RAM. You could try running the System Monitor or the linux program top to see how much memory is being used while running dada2 and see if you are running out and causing the job to be canceled.

Those weird quality scores are from the NextSeq using binned quality score. This could also cause issues with dada2, but should not effect deblur, which is why I think RAM could be the issue.

2 Likes

Thank you so much for your response. We will use a remote server and try to run deblur. I will continue to post here if we encounter any more issues.