q2-itsxpress: UnsatisfiableError

Hi Dr. Adam, I'm trying to update bbmap 38.18 to 38.92, but I got the flowing error:

$ conda install -c bioconda bbmap=38.92
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: \
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
failed

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versions

Package ncurses conflicts for:
python=3.8.10 -> readline[version='>=8.0,<9.0a0'] -> ncurses[version='>=6.1,<7.0a0']
python=3.8.10 -> ncurses[version='>=6.2,<6.3.0a0|>=6.2,<7.0a0']

Package libstdcxx-ng conflicts for:
python=3.8.10 -> libffi[version='>=3.3,<3.4.0a0'] -> libstdcxx-ng[version='>=7.3.0']
python=3.8.10 -> libstdcxx-ng[version='>=9.3.0']

Package _libgcc_mutex conflicts for:
python=3.8.10 -> libgcc-ng[version='>=7.5.0'] -> _libgcc_mutex[version='*|0.1',build='main|main|conda_forge']
bbmap=38.92 -> libgcc-ng[version='>=9.4.0'] -> _libgcc_mutex==0.1=conda_forge

Package libgcc-ng conflicts for:
python=3.8.10 -> libgcc-ng[version='>=7.3.0|>=7.5.0|>=9.3.0']
python=3.8.10 -> openssl[version='>=1.1.1k,<1.1.2a'] -> libgcc-ng[version='>=7.2.0|>=9.4.0']The following specifications were found to be incompatible with your system:

  • feature:/linux-64::__glibc==2.31=0
  • feature:|@/linux-64::__glibc==2.31=0

Your installed version is: 2.31

Do you can help me? Thanks