Plugin error from feature-table: IDs are not present in the metadata

Hello all,

I´m using qiime2-2020.6 and I´m stuck trying to run the following command:

qiime feature-table summarize
--i-table table.qza
--o-visualization table.qzv
--m-sample-metadata-file metadata.tsv

When I run this code, I get the following error:

Plugin error from feature-table:

The following IDs are not present in the metadata: ' CT1', ' CT2', ' CT3', ' CT4', ' CT5', ' CT6', ' Comp-Per', ' Comp-Suc'

Debug info has been saved to /var/folders/b6/_f5bmtm979l33gcthw87c8fr0000gn/T/qiime2-q2cli-err-bbk6owe3.log

I checked the metadata file and the spelling seem to be ok.
I also run the feature-table summarize command without the --m-sample-metadata-file param and the resulting Sample IDs as encoded in my feature table.
I validated the file with Keemei and got no errors.
I´ve checked the following related threads and couldn’t find the solution:

Here I attached the metadata metadata.tsv (275 Bytes) and the table.qzv file table.qzv (434.2 KB) .

I have been previously used the same pipeline and got no errors. Any help would be much appreciated.

Thanks in advance!

Hi @Eva,

It looks like you’ve got spaces in your table names. (’ CT1’) but not your metadata.

You can either re-process your data, or try the nifty rename-ids function to see if that will fix your problem.


1 Like

Thanks Justine! That was silly and simple. Everything worked now :slight_smile:


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.