Problem with FeatureTable

Plugin error from feature-table:

“None of [Index([‘S270’, ‘S268’, ‘S272’, ‘S273’, ‘S269’, ‘S266’, ‘S271’], dtype=‘object’)] are in the [index]”

Debug info has been saved to /var/folders/ll/_2t9tfrd5rd5wx01ksb41gs00000gn/T/qiime2-q2cli-err-0bkwyfip.log

I tried everything but always the same reply. What could be wrong?

Hi @Giulia_Marchioro,

What is the exact command you are trying to run?
This error typically is related to unmatching sample ID names between your metadata file and the ones used to import your sequences. For example, see a similar error here. Can you double check to make sure the sample names in your metadata file are matching the ones you used to import your reads exactly? You can start by the samples mentioned in the error. S270, S268 …etc
Hope that gets things started!

1 Like

qiime feature-table summarize
--i-table table.qza
--o-visualization table.qzv
--m-sample-metadata-file mapping_fileJ793.csv

this is the command Im using.

Anexed is my mapping file and my manifest document that I used to import my data. I double checked and for me there is no unmatching samples ID's

Hi @Giulia_Marchioro - can you please run the feature-table summarize command without the metadata, and provide that here?


qiime feature-table summarize \
  --i-table table.qza \
  --o-visualization table.qzv

This will provide us with an exact list of the sample ids that are being used (there are several steps happening between importing your data and here, so we want to use the data closest to the problem for diagnosis). If you are unable to attach that visualization here publicly due to concerns about privacy, feel free to send in a private message. Thanks! :t_rex:

I run this command and I see that the sample S267 is missing is this list

Thanks @Giulia_Marchioro! Can you also provide a screenshot of:

qiime metadata tabulate \
  --m-input-file mapping_fileJ793.csv \
  --o-visualization mapping_fileJ793.qzv

Also, I am noticing now that your metadata is a CSV, not a TSV file. What version of QIIME 2 are you running? Metadata should only work with TSV files — do you have a copy of your sample metadata file in TSV format, too?

As far as that sample being missing — it would be good to double check the list of samples in the following:

qiime demux summarize \
  --i-data $MY-DEMUX-SEQS.qza \
  --o-visualization demux.qzv

It is possible that the QA/QC step (are you running DADA2 or Deblur?) might be filtering out that sample entirely. Also, I noticed your sequence counts seem pretty low in general - do those counts look right to you? As in, is that what you’re expecting to see based on your extraction, PCR, sequencing, etc?

Anyway, keep us posted! :t_rex:


Im using " qiime2-2017.12"
So, do I have to work just with TSV files for this version? I dont have them in this format. I can do that.
Iam running DADA2, so I just figure out that actually this step might be filtering out my sample because the sequence count is very low.
Actually, we are testing different Primers Pairs into these samples. Also, this is just an activity for me to learn to work in Qiime 2.
But, besides this sample, could I continue with tutorial?

Anexed I sent you my demux file and mapping file

Ah ha - we found the issue! First off, I recommend you upgrade to QIIME 2 2018.2, that is the latest and greatest QIIME 2, and conveniently, it has many new features, including one that would have prevented this from happening in the first place. Okay, so now for some detail as to what is wrong here.

If you look at the screenshot from metadata tabulate, you will notice that you only have one column, called #SampleID,BarcodeSequence,LinkerPrimerSequence,ReversePrimer,Origin,Species,Primer,Sample — this is because you used a CSV file, instead of a TSV file, so that old version of QIIME 2 tried to interpret the CSV as a TSV, and only identified that one column. So, all of your IDs are also suffering from the same issue (they are being smushed together).

Go ahead and upgrade to QIIME 2 2018.2, then spend a little time reviewing the Metadata in QIIME 2 Tutorial.

Have the primers been removed from the reads by the time you send them into DADA2? DADA2 expects that all barcodes, primers, etc. have been removed (so basically, only biological signal is present) — primers can negatively impact the denoising model, as I understand it.

Alright, keep us posted! :t_rex:


Ohhhhh Thank youuu a lot!!

Oh, I meant, I am testing different primers but for this running I was only using one pair. I just said that because maybe this primer is not good for that sample.

Anyways, thank youuu


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.