Plugin error from feature-table:


I am a new-ish QIIME2 user so I apologize for any incorrect terminology use throughout my post. I have tried my best to explain my issue and provide necessary information, but please let me know if there is anything I am missing.

I have been using QIIME2-2018.4 to follow the "Moving Pictures" tutorial with my own data (5 separate datasets) and everything has gone well! However, I am now trying to merge all 5 datasets together. I was able to successfully run the following commands to merge the sequences and FeatureTables from all 5 datasets:

qiime feature-table merge-seqs
--i-data rep-seqs-dada2-almond.qza
--i-data rep-seqs-dada2-broccoli.qza
--i-data rep-seqs-dada2-grains.qza
--i-data rep-seqs-dada2-walnut.qza
--i-data rep_seqs_PATH_all_run123_dada2.qza
--o-merged-data rep-seqs-dada2-USDA-allPATH.qza

qiime feature-table merge
--i-tables table_PATH_all_run123_dada2.qza
--i-tables table-dada2-almond.qza
--i-tables table-dada2-broccoli.qza
--i-tables table-dada2-grains.qza
--i-tables table-dada2-walnut.qza
--o-merged-table table-dada2-USDA-allPATH.qza

However, when I try and run these commands to create a visualization of the merged FeatureTable, the bold part works, but the italicized part brings up an error:

qiime feature-table summarize _
_ --i-table table-dada2-USDA-allPATH.qza _
_ --o-visualization table-dada2-USDA-allPATH.qzv _
_ --m-sample-metadata-file Merged_Mapping_Files_8_29_2018.tsv

qiime feature-table tabulate-seqs
--i-data rep-seqs-dada2-USDA-allPATH.qza
--o-visualization rep-seqs-dada2-USDA-allPATH.qzv

The error is as follows:

From this, I think it's safe to assume that the error is in reference to my broccoli data, as that dataset has exactly 72 sample IDs. However, in my mapping file they have the following naming convention: B.001-B.072. So I went in and changed all the IDs to match what was stated in the error (i.e. 1-72) and tried to run the command again. However, when I did this, I got the same error as listed above but stating that the IDs B.001-B.072 were not listed in the metadata.

Here is a visualization of what some of my metadata looks like:

I'm not really sure how to troubleshoot from here and would appreciate any suggestions and guidance! Thank you in advance!

Hey there @nutrishinn!

It looks like your Sample IDs in your Feature Table aren't what you think they are. Try running the feature-table summarize command without the --m-sample-metadata-file param to see a summary of the Sample IDs as currently encoded in your feature table:

qiime feature-table summarize \
  --i-table table-dada2-USDA-allPATH.qza \
  --o-visualization table-dada2-USDA-allPATH.qzv

My guess is you will see 1, 10, 11`... etc. here.

So, the next question is how did you import? Did you use a fastq manifest format?

:t_rex: :qiime2:

Thank you so much, @thermokarst!

I apparently forgot that another one of my datasets also had 72 samples and that was the one causing the issue. Once I updated the mapping file to match the feature table IDs from that dataset, the command worked!

Thank you for catching something that seems so simple, yet my all-day-immersed-in-QIIME2 brain couldn’t get to that point at the end of the day :sweat_smile: I really appreciate your time and guidance!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.