Plugin error- feature table summarize

Hello all,

I am trying to run this part of the QIIME2 pipleine:

> qiime feature-table summarize \
>   --i-table table.qza \
>   --o-visualization table.qzv \
>   --m-sample-metadata-file /home/mingala/array1/metadata.tsv

When i run this code, I get the following error:

Plugin error from feature-table:

  "None of [Index(['ARLI-C-251689', 'ARLI-G-251716', 'RHAE-C-251185', 'DERO-C-251190',\n       'CHAU-G-251504', 'STLI-G-251197', 'DERO-G-251330', 'PTME-G-251393',\n       'TRCI-G-251383', 'MYKE-G-251195', 'MYKE-G-251331', 'MORU-G-251452',\n       'CHAU-G-251508', 'DERO-G-251344', 'SABI-G-251458', 'ARLI-G-251687',\n       'PTDA-C-251720', 'ARLI-G-251709', 'CASO-C-251367', 'RHAE-G-251163',\n       'STLI-C-251414', 'TRCI-C-251419', 'TRCI-C-251428', 'MYKE-G-251194',\n       'STLI-C-251203', 'LOEV-G-251729', 'MORU-G-251168', 'MYKE-C-251211',\n       'PTME-G-251368', 'URBI-C-251430', 'SABI-C-251699', 'MORU-G-251439',\n       'ARLI-C-251711', 'SABI-G-251697', 'TRCI-C-251516', 'MORU-C-251181',\n       'RHNA-C-251781', 'PTDA-C-251708', 'GLSO-C-251770', 'DEPH-C-251530',\n       'CHAU-G-251509', 'ARLI-C-251715', 'SABI-C-251702', 'MORU-C-251177',\n       'DEWA-C-251535', 'PTME-C-251316', 'EUNA-C-251381', 'DEPH-C-251421',\n       'MORU-C-251441', 'RHAE-G-251553', 'CASO-C-251362', 'MYKE-C-251338',\n       'EXT-NEG', 'DERO-G-251340', 'PCR-NEG'],\n      dtype='object')] are in the [index]"

Debug info has been saved to /tmp/qiime2-q2cli-err-uznqgxp5.log

I checked that the sample IDs match by running the code without passing --m-sample-metadata, and the resulting table.qsv has the correct sample IDs identical to those in my metadata file. The file was validated with Keemei with no errors.

I even tried to run it again, this time replacing the metadata #SampleID column with the full file names from the MiSeq like so:

imageARLI-C-251689_S41_L001_R1_001.fastq.gz

But this threw the same error code. Any ideas about why? Thank you!

Hey @mingala,

That’s pretty strange. Would you be able to DM me (or post if it’s not sensitive) your metadata file and your feature-table? There must be something subtle happening that’s causing this.

Thanks!

1 Like

Thanks for the reply, @ebolyen

Here is the head of the table that results from running the command without -m sample metadata:

And here is my metadata file:

ColonGuanometadata.tsv (7.5 KB)

So far all the names seem to match, which is why I cannot figure out why it produces the error.

1 Like

Hi @mingala! If you look carefully, you will notice that your IDs actually aren’t quite the same between files:

ARLI_C_251689 (in your metadata file) vs ARLI-C-251689 (in your feature table) — note the underscores vs dashes.

If you update your sample metadata file to use dashes you should be in good shape (technically you could also update your feature table to use underscores, but that would be a lot more work — it would require reimporting your data with new ID values and reprocessing to this point, which is why I am recommending just updating your metadata file)! Keep us posted! :t_rex:

1 Like

Wow…that was very silly. But that is what I get from staring at this stuff for too long I guess…thanks a lot!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.