Only half reads pass DADA2 denoise

Hi all,

I am processing my 16S rRNA sequencing data from mice gut, which was sequenced on V3-V4 region. I have two simple questions uncertain:

  1. As this sequencing is completed on NovaSeq6000 which adopts binned quality scores, I wonder whether qimme2 DADA2 is still well compatible with those data?
  2. After DADA2 denoising, only half of the reads remained. I am not sure whether it is normal or not.

Corresponding codes are attached as follows, any suggestion would be greatly appreciated!

qiime cutadapt trim-paired
--p-cores 40
--i-demultiplexed-sequences ./raw/paired-end-demux.qza
--p-error-rate 0.3
--o-trimmed-sequences ./clean_data/paired-end-demux_de_primer.qza
qiime demux summarize
--i-data ./clean_data/paired-end-demux_de_primer.qza
--o-visualization ./clean_data/paired-end-demux_de_primer.qzv

mkdir ASVs
qiime dada2 denoise-paired
--p-n-threads 40
--i-demultiplexed-seqs ./clean_data/paired-end-demux_de_primer.qza
--p-trunc-len-f 222
--p-trunc-len-r 229
--o-table ./ASVs/dada2_table.qza
--o-representative-sequences ./ASVs/dada2_rep_set.qza
--o-denoising-stats ./ASVs/dada2_stats.qza

#---- denoising statistics
qiime metadata tabulate
--m-input-file ./ASVs/dada2_stats.qza
--o-visualization ./ASVs/dada2_stats.qzv
qiime feature-table tabulate-seqs
--i-data ./ASVs/dada2_rep_set.qza
--o-visualization ./ASVs/rep-seqs.qzv

dada2_stats.qzv (1.2 MB)
paired-end-demux_de_primer.qzv (317.7 KB)

1 Like


NovaSeq6000 data still can be processed by Dada2 "as it is". More details here.

based on your stats output, around 85% of reads are passed through the filters (issue not in the binned quality scores), 75% are merged (truncating parameters are ok, though you still can try to improve it), and only 50% passed chimera detection filter. That means that a lot of your reads are considered to be chimeric. I would go back to the primers removal step to make sure that all of them are deleted.


1 Like

Hi @timanix . Many thanks for the suggestion. Now I am much more confident in q2-DADA2 compatible with NovaSeq data. Also, I included the option "--p-discard-untrimmed" to discard reads that did not contain any primer, and quite sure that all primers have been removed.


I missed it from your post.
There is one big discussion with a similar issue, you can go through it to check if some suggestions from there would work for you. Another possibility is to merge your reads with vsearch-merge plugin and then use Deblur to denoise it.


1 Like

Hi, @timanix . Thanks a lot! I will have a try.