"Not a(n) HeaderlessTSVTaxonomyFormat file"

I’ve been stuck on this for a while now, and I can’t quite figure it out. I’m trying to import a reference taxonomy file but I get this error message

There was a problem importing Warcup_RDP_Taxonomy[397].txt: Warcup_RDP_Taxonomy[397].txt is not a(n) HeaderlessTSVTaxonomyFormat file

I’ve went through the training feature classifiers tutorial, however, I’m still stuck. It doesn’t help that I am super new to Qiime2. Below is the file so maybe something I’m missing could be pointed out. Thank you.
Warcup_RDP_Taxonomy[397].txt (419.1 KB)

1 Like

@elfthief,

It looks like the format of your reference taxonomy file is the problem at this point. For the headerless TSV taxonomy format, you want to make sure that you don’t have anything before your data, then each line should look like:

[ID number][tab][full taxonomic identification][newline]

The ID number can be a variety of things, commonly it is an ascension number. The important thing is that these match your data. You also want to make sure that it is a tab separated text file, though the taxonomic identification should be semicolon delimited, as this how downstream tools expect this to be written.

For an example of what it should look like you can look files in the tutorial. You may also want to check out this thread. I actually think they are using the same RDP format you are. Unfortunately, there is no way to bring this format directly into QIIME 2.

Based on looking your data and the referenced thread, you may be able to work with your taxonomy format to get it in a usable form. This is likely going to be a lot of work; if you can get your taxonomy data in a compatible format, that should be your first option.

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.