help with conflicting external packages

Hi all
I have a question, but this query is not directly related to qiime2.
I am trying to install kneaddata on two different systems, both of which have qiime2 already installed.
It works nicely on my laptop but gives error on desktop.
Showing invalid or corrupt jarfile.
Since I am bound to run it on desktop, owing to memory issues with laptop.
Kindly can anyone help or guide hiw to solve this issue.
Note: i downloaded and installed afresh but same error.
Thanks and regards

1 Like

Could You please provide full error message and systems info?

1 Like

Thank you for your prompt response.
Here I am attaching the issue

The same command when I runs on laptop runs smoothly with no errors.
Thanks and Regards

It is known Trimmomatic problem Kneaddata installed with conda is not available - #5 by Ben_Siranosian - KneadData - The bioBakery help forum


I can try to reproduce it on VM tomorrow,

1 Like

Have you any updates?

Hi @ Nikonov_Sergey
No, I am still facing the issue. Since I am new to all these command line softwares and programmes.
So, don't get how to modify my environment as suggested by

Kindly, suggest how to go forward.
and how to use this command line in my environment.
Thanks and Regards

Sorry, see your message just now.
I've already downloaded VM, Let me try to reproduce error.
On the wire.

fast option:

  1. locate your trimmomatic folder (usr/share/trimmomatic or another)
  2. use kneaddata --unpaired demo.fastq --reference-db demo_db --output kneaddata_demo_output --trimmomatic /usr/share/trimmomatic

Hi @ 5cr34m
thank you so much for your help.
Alternatively, I was trying to install biobakery_worflows by getting same issues there
It is successfully installed on laptop and gives error on desktop, (showing python related issues)
Again, this command conda install -c biobakery biobakery_workflows ran in my laptop, but later on gave error because of citing memory error
In case of my desktop while running the same command it gave this error
qiime2@qiime2core2020-11:~$ conda install -c biobakery biobakery_workflows
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
****Solving environment: | ****
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
****failed ****

UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:


**** - biobakery_workflows β†’ python[version=β€˜>=2.7,<2.8.0a0|>=3.7,<3.8.0a0’]****

Your python: python=3.8

If python is on the left-most side of the chain, that’s the version you’ve asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Note that conda will not
change your python version to a different minor version unless you explicitly specify

The following specifications were found to be incompatible with your system:

**** - feature:/linux-64::__glibc==2.27=0****
**** - python=3.8 β†’ libgcc-ng[version=β€˜>=11.2.0’] β†’ __glibc[version=β€˜>=2.17’]****

Your installed version is: 2.27
If possible please have a look at this issue as well, and suggest how I can install this successfully.
thanks and Regards

try pip3 install biobakery_worflows

The problem is in 2 different python versions in qiime2 VM

2.7 & 3.8

Hi @5cr34m
Thank you so much for prompt response and help through out.
Yes, I know there is such issue with my installation process.
But What is the way forward to solve this issue and what codes/ commands to run to fix this issue and get the installation successful.
Kindly give the step and commands.
Thanks and regards

try pip3 install biobakery_worflows

Hi @5cr34m
i trust you are well
I tried for kneaddata but failed again.
Attached is the detailed overview of the command I ran and the errors I got.
please find and suggest where i am committing mistakes
thanks and regards
error.txt (9.6 KB)

  1. uninstall all trimmomatic versions or simply use new copy of VM
  2. install latest via conda install -c bioconda trimmomatic
  3. check:
    VirtualBox_QIIME 2 Core - 2022.2 (1654113933)_19_08_2023_00_48_14

Hi @5cr34m
Thank you so much
let me give it a try.

you're welcome.
i'll be online 2 h. at least.
regards, sn

Thank You so much @5cr34m
Mean while I installed biobakery_worflows and downloading is on
Need to understand the workflow

1 Like