Handling paired-end dual indexed Illumina FASTQ files

Dear QIIME2-community,

I am totally new to QIIME and QIIME2. I want to analyse paired-end dual indexed Illumina reads, which means I have 4 FASTQ files (R1 and R2 with microbial sequences, I1 and I2 with barcode sequences).
I (think I) thoroughly checked the documentation and learned that there was a method in QIIME (http://qiime.org/tutorials/processing_illumina_data.html#two-index-barcode-reads-and-two-fastq-reads), but that you cannot easily use this function in QIIME2 and that you are still working on this (https://github.com/qiime2/q2-demux/issues/62). The recommendation is to process sequences with QIIME and then analyse the result with QIIME2 (Importing multiplexed paired-end data with separated barcode sequence files), but I am not able to make this work.
I am using QIIME2 2020.2 via VirtualBox.

I would like to know if there will be a solution to this problem soon? Otherwise I would appreciate any help with using old QIIME python scripts in QIIME2 (if possible) or any other workarounds.
Would it be possible to demultiplex with demux EMP-single two times two files and join forward and reverse reads afterwards?

Thanks a lot!


Hi Loui,
Welcome aboard!
I wouldn’t hold my breath for this functionality to be released in the near future, I don’t see it on the radar for at least the next release. So sticking with the Q1 approach linked in the other post is probably your best bet.

Can you give us a bit more detail regarding what you tried exactly, and where you were unable to get this to work? Did you follow the instructions in the other thread?

Dear @Mehrbod_Estaki,

Thanks a lot for your reply, that’s already very good to know.

Well, I am also new to python and the terminal :blush:, so I tried to just type the command “extract_barcodes.py”, which does not work because QIIME2 doesn’t take any python commands if I understood correctly. I also tried to save the “extract_barcodes.py” script manually and call it in the terminal, which produced another error (“ImportError: cannot import name upper”).
But apart from the details, is it possible to somehow activate QIIME(1) python commands in QIIME2? Or do I have to set up QIIME(1) in another Virtual machine and run the python scripts there?

Thank you!

1 Like

Hi @Lou,
Aha, gotcha. Ok so you want to think of QIIME 1 and QIIME 2 as two completely different entities that need to bet set up separately. You can’t run scripts from one in another. You’ll need to install QIIME 1 separately into a new conda environment, activate it and run the commands from that link specifically there, and once you have got the outputs you need, then activate your QIIME 2 environment and migrate your data there.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.