Failed in Reads merging

Dear Qiime2 members,

Previously I am facing some issue with filtering step in dada2 plugin. But now filtering step is ok but I am facing problem in merging. Can any one tell me where is the problem. 0 reads merged in dada2 plugin. Please solve this problem.
My command -

> qiime dada2 denoise-paired --i-demultiplexed-seqs trim-cov-paired-end-demux.qza --p-trunc-len-r 0 --p-trunc-len-f 0 --p-max-ee-f 4.0 --p-max-ee-r 4.0 --p-trunc-q 25 --p-n-threads 0 --o-table cov-table-q25.qza --o-representative-sequences rep-seqs-cov-q25.qza --o-denoising-stats denoising-stats-cov-q25.qza --p-chimera-method consensus --verbose

If with --p-trunc-q 25 I am giving --p-trunc-len-f 250 and --p-trunc-len-r 200 , then I am getting a technical error. Please kindly look into this matter.
Error -

Thank You

Hi @Rishikesh12,

What do your sequence quality plots look like? That is your visualization output form qiime demux summarize ... ?

See the Atacama or the Microbiome Intervention Tutorial for some examples of quality assessment and merging of paired-end data. Note on the latter link you may have to select Command Line q2cli from the drop menu at the top of the page.

The idea with these steps is that we need to help the denoiser a little. That is, we need to remove the obviously poor quality sections of the reads, so that the denoiser will be better able to denoise the sequences without being swamped with to much noise from bad sequencing data. Thus, we need to trim / truncate these poor regions.

Poor quality sequences often occurs at the end of each paired read, meaning that the region of overlap can be too noisy and prevent merging, as there are too many mismatches between the read pairs. Also, be sure that your reads are providing a reasonable level of overlap to be merged. There are many other threads on the forum that discuss how to figure out how much overlap you may need, given your amplicon.

I also noted that you are using --p-max-ee-f 4.0 --p-max-ee-r 4.0 --p-trunc-q 25. These may actually be too strict, at least the --p-trunc-q 25 setting might be. Read the help text for these options to make sure these are the settings you want. For example, --p-trunc-q 25 will truncate the sequences at the first occurrence of a base with a score of 25 or lower. This could mean you'll obtain very short sequences that will unable to be merged.

When you merge reads, the low quality bases in the region of overlap, could be "rescued" if the same base is called at the same position from the other read, even if it is low quality too. That is, you'll have two independent pieces of evidence that a given base call might be correct. Perhaps leave -p-trunc-q using the default setting, or lower it to 10? Let the denoiser "figure things out"? It might be that for this data, you are helping the denoiser too much. :man_shrugging:

1 Like

Hi @SoilRotifer ,
Thank You for your response to the my issue. I have attached the quality of the reads after adapter trimming.

As per your suggestion, I tried reducing --p-trunc-q to 20 and 15, and also adjusted --p-max-ee-f and --p-max-ee-r to 2.0. However, despite these adjustments, some samples still had 0 reads to merge. I have included the denoise stats for q20 and q15 for your reference.

Interestingly, when using q20, I observed 9 samples with 0 reads merged, whereas with q15, the number increased to 17 samples with 0 reads to merge. This has made me hesitant to further reduce --p-trunc-q.

I also have a question regarding the default --p-trunc-q value, which is 2, and as you suggested q10. I am unsure if the results obtained with the default value will be acceptable for publication?

I will try your other suggestions, such as exploring the Atacama and the Microbiome Intervention Tutorial.

Thank You

You should not have an problems with the default quality of 2. Remember, the denoiser will still be doing extra work to clean the sequences. The quality filtering is only an initial step. I would also avoid setting --p-trunc-len-f 0 --p-trunc-len-r 0. Perhaps use --p-trunc-len-f 270 --p-trunc-len-r 190? Run this first without any other parameters. This should give you an upper bound of what is possible to merge. Once successful, then you can try the other settings.

1 Like

Hey @SoilRotifer ,
As you said previously we should help denoiser a little. I followed Atacama and Microbiome Intervention Tutorial. Then I set --p-trunc-len-f 290 --p-trunc-len-r 200 --p-trim-left-f 5 --p-trim-left-r-5 and kept all other parameters default. I get a very good result. I am attaching the file for your reference.

denoising-stats-cov-new1.qzv (1.2 MB)

Did you thing if i will change --p-trunc-len-f 270 and --p-trunc-len-r 190 and keep all other paramters as default value it will improve the results more?

Thank you

Hi @Rishikesh12,

That is certainly an improvement! :raised_hands:

This is one of those cases were you'll just have to try a few different iterations and see what works best. It seems like everything substantially improved except for what it considers chimeras. I suspect trying different truncation values should help reduce chimeras.

Just an FYI, I often like to use the --p-pooling-method pseudo --p-chimera-method pooled options. You can also try those after you narrow down the truncation settings.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.