Error when running q2-demux

Yes yes, thanks a bunch, I just did that.
Another issue is my multiplexing script. I have 8nt nucleotides instead of 12nt. How do I manipulate the command? I used the following command , the error was also attached:

qiime demux emp-paired \

–m-barcodes-file sample-metadata.tsv
–m-barcodes-column BarcodeSequence
–p-rev-comp-mapping-barcodes
–i-seqs emp-paired-end-sequences.qza
–o-per-sample-sequences demux-full.qza
–p-golay-error-correction-details demux-details.qza

Error report:
1/1?) no such option: --p-golay-error-correction-details (Possible options:
–o-error-correction-details, --p-golay-error-correction, --p-no-golay-
error-correction).
I found the ‘golay error correction’ for the single-end reads.

Kindly advise, please.

Betty.

Hello @bettya,
There are kind of two problems here.
First let’s address the error: The error is not because you have 8nt vs 12nt ( Although that will be a problem). It is actually causing an error because there is no parameter named --p-golay-error-correction-details. You want either--p-golay-error-correction or --p-no-golay-error-correction. or If you want to print error correction details you will have to use this output option: –o-error-correction-details. All this is detailed in your error as well.

Now having said that, let’s talk about you having 8nt rather then the 12nt. Unfortunately from what I understand you cant use the --p-golay-error-correction because you have 8nt and not the required 12nt. You will have to use this parameter : --p-no-golay-error-correction. Here is a post talking about the same thing.
Hope this helps!
Chloe :turtle:

Hi Chloe
Thank you for the advice
I am unable to demux despite adding the ‘no golay error correction’. I attached the error log and I also verbose the command.

qiime demux emp-paired \

–m-barcodes-file sample-metadata.tsv
–m-barcodes-column BarcodeSequence
–p-rev-comp-mapping-barcodes
–p-no-golay-error-correction
–i-seqs emp-paired-end-sequences.qza
–o-per-sample-sequences demux-full.qza
–o-error-correction-details demux-details.qza

Error message:
Plugin error from demux:

No sequences were mapped to samples. Check that your barcodes are in the correct orientation (see the rev_comp_barcodes and/or rev_comp_mapping_barcodes options). If barcodes are NOT Golay format set golay_error_correction to False.

Debug info has been saved to /tmp/qiime2-q2cli-err-qwrvu0un.log

Adding verbose to the command:
qiime demux emp-paired \

–m-barcodes-file sample-metadata.tsv
–m-barcodes-column BarcodeSequence
–p-rev-comp-mapping-barcodes
–p-no-golay-error-correction
–i-seqs emp-paired-end-sequences.qza
–o-per-sample-sequences demux-full.qza
–o-error-correction-details demux-details.qza
–verbose
Traceback (most recent call last):
File “/home/qiime2/miniconda/envs/qiime2-2020.11/lib/python3.6/site-packages/q2cli/commands.py”, line 329, in call
results = action(**arguments)
File “”, line 2, in emp_paired
File “/home/qiime2/miniconda/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 245, in bound_callable
output_types, provenance)
File “/home/qiime2/miniconda/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 390, in callable_executor
output_views = self._callable(**view_args)
File “/home/qiime2/miniconda/envs/qiime2-2020.11/lib/python3.6/site-packages/q2_demux/_demux.py”, line 467, in emp_paired
raise ValueError('No sequences were mapped to samples. Check that ’
ValueError: No sequences were mapped to samples. Check that your barcodes are in the correct orientation (see the rev_comp_barcodes and/or rev_comp_mapping_barcodes options). If barcodes are NOT Golay format set golay_error_correction to False.

Plugin error from demux:

No sequences were mapped to samples. Check that your barcodes are in the correct orientation (see the rev_comp_barcodes and/or rev_comp_mapping_barcodes options). If barcodes are NOT Golay format set golay_error_correction to False.

See above for debug info.

Kindly assist.
Regards.

Hello again @bettya!
So there problem again described is in the error that you sent:

You are using p-rev-comp-mapping-barcodes but it was not able to map the barcodes to the sequences using p-rev-comp-mapping-barcodes. So I am not 100% sure how your data is set up but you might want to not use p-rev-comp-mapping-barcodes.

The error says that your barcodes might be in the wrong orientation. I would suggest trying the opposite option that you used:--p-no-rev-comp-mapping-barcodes so that the barcodes are not reverse complemented.

Hope this helps!
Chloe :turtle:

An off-topic reply has been split into a new topic: 2021: An error was encountered while running DADA2 in R (return code -9)

Please keep replies on-topic in the future.