2021: An error was encountered while running DADA2 in R (return code -9)

Hi Chloe

Thanks for your response.
I used both ‘p-rev-comp-barcodes’ and ‘p-rev-comp-mapping-barcodes’ and it worked.
The command:

qiime demux emp-paired \

–m-barcodes-file sample-metadata.tsv
–m-barcodes-column BarcodeSequence
–p-rev-comp-barcodes
–p-rev-comp-mapping-barcodes
–p-no-golay-error-correction
–i-seqs emp-paired-end-sequences.qza
–o-per-sample-sequences demux-full.qza
–o-error-correction-details demux-details.qza
Hurray!
DENOISING PAIR-END READS
I have an issue with the denoising command. I do not want to trim my reads so I used this command:
qiime dada2 denoise-paired
–i-demultiplexed-seqs demux-full.qza
–p-trim-left-f 0
–p-trim-left-r 0
–p-trunc-len-f 151
–p-trunc-len-r 151
–o-table table.qza
–o-representative-sequences rep-seqs.qza
–o-denoising-stats denoising-stats.qza
Error:
Plugin error from dada2:

An error was encountered while running DADA2 in R (return code -9), please inspect stdout and stderr to learn more.

Debug info has been saved to /tmp/qiime2-q2cli-err-mk4sd79d.log
What am I missing please?

Hi Chloe

These are my plots and table summaries from the demux.qzv:

image

The region is V4, the primers are 515/806.
I have reads that comprises of 12 samples (12 forwards and 12 reverse) and no sample must be lost due to the type of analysis. Samples were run in 3 batches. I have 8nts in my reads. I believe I have a very good reads as shown by the bar plot.
What is the basis of trimming? How can I trim and merge the reads and still get a good cluster for my samples?
Thank you for your timely response.

Hello @bettya ,
Thank you for all the information
Unfortunately I am not sure what your error is to be honest.
Could you less /tmp/qiime2-q2cli-err-mk4sd79d.log and send me a screenshot of the result so that I can better understand the error? Or you could run the same command with the --verbose. parameter that would also give us more information. Currently I don’t understand fully what the error is and so I don’t know what the problem is.

The reason for trimming is to remove your primers if they are still in the sequences. :qiime2:

You should be able to trim at 0 if you don’t have a primer in your sequences. I do it all the time! :grinning: Again I think I just need more information about the original error.
Thank you
Chloe :turtle:

Hey @bettya,
I think your issue is actually lack of memory.
If DADA2 throws a -9 error code it means that DADA2 was not able to complete the command with the amount of memory given.
So I would run this command on a computer that has more memory.
I hope this helps!
Chloe :turtle:

1 Like