Error after denoising protocols.

Hi guys,

basically, I am a new qiime2 user. I stucked at the point after denoising, which I did with dada, deblur and vsearch producing visualizable tables. Unfortunately, when I try to do phylogenetic analysis or taxonomy assignment of my ASVs I always encountered this error: “BAD REQUEST - <class ‘qiime2.core.type.grammar.UnionExp’> object has no attribute ‘decode’” with graphical user interface.
May you help me? thank you in advance.

Stefano

Hi, @Stefano!

Welcome to the forum! :slight_smile:

Can you attach a screenshot of q2studio before you submit the job (i.e., press Go!) that is failing?

I think you may have actually discovered a bug :bug:! I’ll see if I can come up with a fix for this. Stay tuned.

Cheers,
Andrew

1 Like

Thank you @andrewsanchez for your reply! I attached screenshots as requested:

Screenshot from 2020-04-17 15-28-28

Alternatively, could you provide me the exact command line to write down in the terminal? I’ve tried it in many ways without any good results :frowning_face: :frowning:. I am starting to dream real taxonomy bar charts when I sleep :smiley:. I just suspect that it is not a bug of qiime2 2020.2 but only something that I am missing.

Thanks again!

Regards
Stefano

1 Like

Hi, @Stefano,

Thanks for the screen shot! I was able to reproduce the error and am looking into a solution.

I’m happy to hear that they are dreams and not nightmares!

I’d be glad to help you with that! Would you mind creating a new topic for this question first? This will help us keep things organized and help others find answers when searching the forum. Please include as much detail as possible, including what you tried, what the expected outcome was, and the actual results you got. Feel free to tag me in that new post. For a general tutorial on feature classification, please see https://docs.qiime2.org/2020.2/tutorials/feature-classifier/

Cheers,
Andrew

2 Likes

Ok @andrewsanchez! Hopefully, It won’t be a nightmare.
I’ll create a new post explaining in details what I’ve tried using the terminal and showing the outcome with screenshots.
Thank you! Bye
Stefano