An error was encountered while running qiime feature-table filter-seqs

Hi Everyone,

I’m trying to use the feature-table filter-seqs function, added in qiime2-2020.8.

I’m using this command below:

qiime feature-table filter-seqs
–i-data BR_rep-seqs_nonchim.qza
–m-metadata-file BR_table_nonchim_nonsingle.qza
–o-filtered-data p476_rep-seqs_nonchim_nonsingle.qza

And I had an error:
Plugin error from feature-table:

All features were filtered out of the data.

Debug info has been saved to /tmp/qiime2-q2cli-err-wsjlmt9w.log

What I’m trying to do is filtering my representative sequences in order to remove singletons and doubletons. I did it with my table, but I don´t know how to do it for my sequences.


qiime feature-table filter-features
–i-table BR_table-nonchim.qza
–p-min-frequency 3
–o-filtered-table BR_table_nonchim_nonsingle.qza

Hello @fellora,
Welcome to the QIIME2 Community!! :qiime2:
I am not sure why this isn't working. Maybe it could be a problem with your metadata file?

Something I would try, if you are able to filter your table, is to use your table to filter your rep-seq.
Here is the docs for qiime feature-table filter-seqs to show you what parameters are allowed for this command.
Basically what I am suggesting is instead of using the --m-metadata parameter use the --i-table parameter and use your filtered table.
I hope that makes sense and helps!
Chloe :turtle:


Thanks @cherman2,

it works!!!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.