Trim primers using "linked" adapters (combined 5’ and 3’ adapter)

I am trying to remove primers using cutadapt in qiime2. I have demultiplexed paired-end data. I first ran my data through dada2 without any trimming, and the resulting seqs contain both the F and R primer, with some additional bases on either end. In the trim-paired documentation, it says to use the --p-adapter for linked primers, and follow details from

Thus I ran the following code:

qiime cutadapt trim-paired
–i-demultiplexed-sequences demux.qza
–o-trimmed-sequences demux-trimmed.qza
–output-dir output

But I got an error saying:
cutadapt: error: Character ‘…’ in adapter sequence ‘ACTGGGATTAGATACCCC…CTAGAGGAGCCTGTTCTA’ is not a valid IUPAC code. Use only characters XACGTURYSWKMBDHVN.

Clearly it is not recognizing the “…” between the primer sequences. This is puzzling because I found this past forum entry that said that such syntax worked well (but appears to have been for single-end data).

Do you have any suggestions for getting this to run correctly. I am relatively novice at this, so it is likely that I am missing something simple.

Hey there @Trodgers!

It looks like an ellipsis accidentally made its way into your command --- this should actually be a ... (three . characters in a row). I just tried it out here locally and the dots work as expected, but the ellipsis fails. Hopefully just updating your command should get you moving in the right direction!

:t_rex: :qiime2:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.