Taxa Barplot Error "Unhashable type: 'Float64Index'"

Hi Forum,

I am having a similar issue as these two threads: Taxa Bar Plot Error - Unhashable type: 'Float64Index' and Unhashable type: 'Float64Index' however I'm fairly certain that I'm using all the correct input files.

My command is:

qiime taxa barplot
--i-table no-misses-filtered-table-f270-r240.qza
--i-taxonomy sample-taxonomy-silva-99-hits-un-extracted.qza
--m-metadata-file SampleMetadata.txt
--o-visualization taxa-bar-plots-silva-99-f270-r240-hits-un-extracted.qzv

The error log is:

File "/usr/local/miniconda/envs/qiime2-2017.10/lib/python3.5/site-packages/pandas/core/", line 1699, in groupby
return klass(obj, by, **kwds)
File "/usr/local/miniconda/envs/qiime2-2017.10/lib/python3.5/site-packages/pandas/core/", line 392, in init
File "/usr/local/miniconda/envs/qiime2-2017.10/lib/python3.5/site-packages/pandas/core/", line 2677, in _get_grouper
if gpr in obj:
File "/usr/local/miniconda/envs/qiime2-2017.10/lib/python3.5/site-packages/pandas/core/", line 909, in contains
return key in self._info_axis
File "/usr/local/miniconda/envs/qiime2-2017.10/lib/python3.5/site-packages/pandas/core/indexes/", line 348, in contains
if super(Float64Index, self).contains(other):
File "/usr/local/miniconda/envs/qiime2-2017.10/lib/python3.5/site-packages/pandas/core/indexes/", line 1640, in contains
File "/usr/local/miniconda/envs/qiime2-2017.10/lib/python3.5/site-packages/pandas/core/indexes/", line 1667, in hash
raise TypeError("unhashable type: %r" % type(self).name)
TypeError: unhashable type: 'Float64Index'

I've attached the input files here.

SampleMetadata.txt (1.5 KB)
sample-taxonomy-silva-99-hits-un-extracted.qza (176.0 KB)
no-misses-filtered-table-f270-r240.qza (422.2 KB)

Would love any advice you have!


Hi @Hillary_Smith! I noticed you’re using the 2017.10 release of QIIME 2. At this time we’re only able to provide support for the latest release, which is currently 2017.12. Can you please try installing that release?

I tried rerunning the command with your data set in the 2017.12 release and I receive the same error message. It looks like none of the 447 feature IDs in your feature table (no-misses-filtered-table-f270-r240.qza) are contained in the taxonomy annotations (sample-taxonomy-silva-99-hits-un-extracted.qza). Is it possible those files got mixed up at some point? You can take a look at the data provenance for those files using, that may help you with tracking this down.

Note: The error message being raised by qiime taxa barplot isn’t very helpful with determining what went wrong. We have an open issue to improve the error message in a future release. We’ll follow up here when that’s available!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.