./silva-132-99-nb-classifier.qza' is not a QIIME 2 Artifact (.qza)

Hello,
I know this topic is not new but I have read every response of others, I tried everything that was suggested but I still have the same problem.
I’m using qiime2 version 2019.7, and the silva-132-99-nb-classifier.qza. When I run the command : qiime feature-classifier classify-sklearn --i-reads rep-seqs-dada2.qza --i-classifier ./silva-132-99-nb-classifier.qza --o-classification taxonomy.qza
I get this message : Invalid value for “–i-classifier”: ‘./silva-132-99-nb-classifier.qza’
is not a QIIME 2 Artifact (.qza)

It’s not a path problem, because everything is in the same folder.
I see it was a space problem, but the computer is new so it’s the first time that I’m using it.
I tried this : $ export TMPDIR=’/data’
Then I tried to run the command again but it did not work.
Could you help me to figure it out please ?
Thank you.

Naëma.

Hi @nbezia01,

Welcome to the :qiime2: forum!

It sounds like the artifact is in your path, which is a good start! What’s the classifier. origin? Have you tried checking if it’s a valid qiime2 artifact by dropping it into qiime2 view?

Best,
Justine

Hi @jwdebelius,
I downloaded the classifier from this website: https://docs.qiime2.org/2019.7/data-resources/
After putting it in qiime2 view as suggested, I got an error message. Then the format of the classifier changed in my computer I don’t know how (it was unzipped) and now it’s running.

Thanks a lot.

Naëma

1 Like

Hi @nbezia01,

I’m glad you’ve solved it.

I’m also going to recommend that if you’re starting a new project, you may want to update your installation. If you have conda, it’s super easy to run multiple versions (even if you have a semi closed server system) and you’ll find it more compatible with new features.

Best,
Justine

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.