SILVA 128 Classifier Error

Hello all!!
I have problem to create the Classifier with SILVA 128 database, for region V1V2 of 16S; In Data Resources webpage I checked the “Silva (16S/18S rRNA) QIIME-compatible SILVA releases” and dowloaded the Silva_128_release.tgz.

I had no problem to obtain the 99_otus_16S.qza and the ref-taxonomy99.qza.

I run the “qiime feature-classifier extract-reads” command to obtain “ref-seqs99.qza”, and it worked.

But when I run the “qiime feature-classifier fit-classifier-naive-bayes”, the command was “killed”…

In “Taxonomy classifiers for use with q2-feature-classifier” section I saw there is a Naive Bayes classifiers trained on SILVA 119; so I would like to ask if Silva 119 99% OTUs full-length sequences is the same of the classifier I was trying to create using SILVA 128 database.

Thank you all!!!

Sara

Hi @SDA89,
Thanks for posting this issue. Could you please give us the following information:

  1. please post the full error traceback for the “killed” error that you are receiving?
  2. How much memory does your machine have? “killed” would seem to suggest a memory error, which is a common issue when working with the SILVA database on many home computers (e.g., laptops with low RAM). The SILVA database is rather large and many laptops cannot handle memory-intensive tasks such as training a new classifier… if you have access to a more powerful computer or cluster, that should solve this issue.

119 is a slightly earlier version of SILVA, but this classifier should suit your needs. Make sure you use the full-length classifier, and not the classifier trimmed to 515F/806R (which is V4). In spite of the recommendation that trimming to your primer region improves accuracy, I will say that in my experience this accuracy boost is not so dramatic that it should hold you back from using a pre-existing classifier if memory constraints create a bottleneck for generating a new classifier…

I hope that helps!

Dear @Nicholas_Bokulich, thank you for your reply.

The error that occur when I’m trying to run the qiime feature-classifier fit-classifier-naive-bayes command is just:

[1]+ Killed qiime feature-classifier fit-classifier-naive-bayes --i-reference-reads ./SILVA/refV4-seqs99.qza --i-reference-taxonomy ./SILVA/ref-taxonomy99.qza --o-classifier ./SILVA/classifier_SILVA99_V4.qza
(qiime2-2017.10) $

I didn’t know that it cuold be a memory problem! I will try to run the command from a more powerful computer!!

thank you very much for your kind explanation!!

Best regards

sara

Hi @SDA89,
Thanks for the details! I see now there are not more details — I was assuming that there may be an error message coming from QIIME2, which should provide a more informative method, but this confirms that it is an issue outside of QIIME2. It sounds like this is what’s going on, which confirms my prediction that this is a memory issue.

Using a more powerful computer should solve your issue — SILVA can take quite a lot of memory to train, though, so you may want to use the pre-trained SILVA 119 full-length classifier if you cannot get access to enough power.

Good luck!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.