RESCRIPT says it installed, but I cannot use it

Hello. I am using Ubuntu version 22.04.3 LTS, with Miniconda 23.7.4. I tried installing QIIME2 and RESCRIPT with the command

conda create -y -n rescript
conda activate rescript
conda install \
  -c conda-forge -c bioconda -c qiime2 -c -c defaults \
  qiime2 q2cli q2templates q2-types q2-longitudinal q2-feature-classifier 'q2-types-genomics>2023.2' \
  "pandas>=0.25.3" xmltodict ncbi-datasets-pylib

but when I try to use RESCRIPT, it says

Error: QIIME 2 has no plugin/command named 'rescript'.

Could someone help me troubleshoot it?
I've previously tried it two other systems running Ubuntu, but those wouldn't even get that far.

Hi @laur34,

If you intend to run the RESCRIPt plugin via your QIIME 2 environment, you need to follow the instructions outlined under Option 2. Assuming you've already installed QIIME 2 as per these instructions.

For example you'd run the following to install RESCRIPt into an existing QIIME 2 environment. Preferably, into a recent version of :qiime2: :

conda activate qiime2-2023.7 
conda install -c conda-forge -c bioconda -c qiime2 -c -c defaults \
  xmltodict 'q2-types-genomics>2023.2' ncbi-datasets-pylib

Then run:

pip install git+

Let us know if that works.



Hi Mike,

thanks for the reply. I tried what you said. This is how far I got:

conda remove --name rescript --all
conda update conda
conda env create -n qiime2-amplicon-2023.9 --file qiime2-amplicon-2023.9-py38-linux-conda.yml
rm qiime2-amplicon-2023.9-py38-linux-conda.yml
conda activate qiime2-amplicon-2023.9
qiime --help
conda install -c conda-forge -c bioconda -c qiime2 -c -c defaults   xmltodict 'q2-types-genomics>2023.2' ncbi-datasets-pylib

but it ended up with a very long list of dependency problems. Longer than the history in my terminal, so I didn't catch all of it.
If you have any more suggestions, please feel free to leave them here.

Hi @laur34,

We're still refining some details now that we have multiple distributions for 2023.9.

After corresponding with a few other :qiime2: devs, there are two approaches for making use of RESCRIPt:

  1. You can install into your current version of QIIME 2, using these updated commands:
conda install -c conda-forge -c bioconda -c qiime2 \
-c  \
-c defaults   xmltodict 'q2-types-genomics>2023.5' ncbi-datasets-pylib

pip install git+

qiime dev refresh-cache

qiime rescript --help

I just tried this myself and it seems to work fine on my end.

  1. If the above does not work for you, you can install the shotgun distribution, which already has RESCRIPt installed, and simply switch to that environment and run RESCRIPt from there. Then switch back to the amplicon distribution to carry out the rest of your work.

Let us know if this works.



Dear Mike,
it worked. :star_struck:
Thank you very much for helping me install RESCRIPT.


No worries! Happy :qiime2: -ing!

1 Like