ITS fungal feature-classifier classify-sklearn error

I got this error:

Plugin error from feature-classifier:

not enough values to unpack (expected 2, got 0)

Debug info has been saved to /var/folders/b0/0dmfv10d27723sxsp8pg9_sh0000gn/T/qiime2-q2cli-err-73e4leaa.log

While I ran this code
qiime tools import
--type ''FeatureData[Sequence]''
--input-path /export/home/......./sh_refs_qiime_ver9_99_s_25.07.2023.fasta
--output-path /export/home/......./unite-ver7-99-seqs-25.07.2023.qza

qiime tools import
--type ''FeatureData[Taxonomy]''
--input-path /export/home/....../sh_taxonomy_qiime_ver9_99_s_25.07.2023.txt
--output-path /export/......./qiime/unite-ver7-99-tax-25.07.2023.qza

qiime feature-classifier fit-classifier-naive-bayes
--i-reference-reads /export/home/......./unite-ver7-99-seqs-25.07.2023.qza
--i-reference-taxonomy /export/......./unite-ver7-99-tax-25.07.2023.qza
--o-classifier /export/home/......./unite-ver7-99-classifier-25.07.2023.qza

qiime feature-classifier classify-sklearn
--i-classifier /export/......./unite-ver7-99-seqs-25.07.2023.qza
--i-reads /export/......./dada2_rep_set_ITS.qza
--o-classification /export/......./qiime/taxonomy.qza

Hi @Parikrama_Sapkota,
Seems like a couple of users had this same issue: Plugin error from feature-classifier: not enough values to unpack (expected 2, got 0) and Feature Classifier - Not enough values to unpack

Can you look into these post and see if it applies to your error?

Hope that helps!
:turtle:

1 Like

Thank you.
According to that post, I am to look for "#" in my txt file. However, when I opened it, I see (below):

Feature ID Taxon
SH0000020.09FU_OM972481_reps_singleton k__Fungi;p__Basidiomycota;c__Agaricomycetes;o__Gomphales;f__Gomphaceae;g__Ramaria;s__Ramaria_sp;sh__SH0000020.09FU
SH0000021.09FU_KY462650_reps_singleton k__Fungi;p__Basidiomycota;c__Agaricomycetes;o__Gomphales;f__Gomphaceae;g__Ramaria;s__Ramaria_sp;sh__SH0000021.09FU

So, I don't see "#" to change;
Any help is appreciate to navigate this!

Hi @Parikrama_Sapkota,
I don't believe that the issue, if you don't have a '#' in your file.

The first link talks about this happening when your feature ids in your rep-seqs aren't the same as the ones in your taxonomy. I think this might be what is going wrong in your case.

Please investigate the feature-ids in both your rep-seqs and taxonomy and verify they are the same!

I hope that helps!
:turtle:

Hi Chloe,
would you mind explaining bit more on this, I am lost on this. I don't understand why I have to look for rep-seqs and taxonomy from my 16S while I am trying to train classifier for ITS?
Any info is very very much appreciated!!

Sincerely,
Pari

Hi @Parikrama_Sapkota,
Can you post or DM the rep-seqs file that you are trying to classify so I can take a look at it?

Hi @Parikrama_Sapkota

Nothing seems wrong with your rep-seqs file, so thats good! Is it possible for you to send me your classifier as well? If its too big to send, could you upload it to google drive, dropbox, etc. and share the link with me?
Sorry, this Debugging is taking a while! I promise we will get to the bottom of it :mag:

No worries. It's been slow here due to holiday seasons. Slowly but surely I believe. Thank you for your patience with me.
Here is the link Sign in to your account

Hi @Parikrama_Sapkota,

I just wanted to mention that you can follow this RESCRIPt tutorial to automatically download, curate, and train a UNITE classifier.

If you are running the latest version of QIIME 2 (2023.9), follow these RESCRIPt install instructions. Otherwise, follow the instructions here.

-Cheers!
-Mike

4 Likes

thank you. I will try it and let you know.

1 Like

Hi @SoilRotifer

I downloaded
conda install -c conda-forge -c bioconda -c qiime2 -c 2023.5-tested -c defaults
xmltodict 'q2-types-genomics>2023.2' ncbi-datasets-pylib

Your installed version is: 2.17
And also did pip install

(qiime2-2022.8) -bash-4.2$ qiime rescript get-unite-data \

--p-version 9.0 \
--p-taxon-group /export/home///UNITE-ALL/sh_taxonomy_qiime_ver9_97_all_25.07.2023.txt \
--p-cluster-id /export/home///UNITE-ALL/sh_taxonomy_qiime_ver9_dynamic_all_25.07.2023.txt \
--p-no-singletons \
--verbose \
--output-dir /export/home///UNITE-ALl/uniteDB

Error: QIIME 2 plugin 'rescript' has no action 'get-unite-data'. Did you mean 'get-ncbi-data'?

But then I got this error?
Why is it asking for NCBI data ?

Hi @Parikrama_Sapkota,

What version of QIIME 2 are you running? I'd recommend using the latest version of QIIME 2 (qiime2-amplicon-2023.9). As I indicated previously, the install command for the latest version of QIIME 2, is slightly different than the one outlined on the github page. The forum post I linked to should help.

Also, for the conda install, if you are using 2023.9 use:

-c https://packages.qiime2.org/qiime2/2023.9/shotgun/released/ 

If using 2023.7, then use:

-c https://packages.qiime2.org/qiime2/2023.7/tested/

If using 2023.5

-c https://packages.qiime2.org/qiime2/2023.5/tested/

Sorry for the confusion, we're still working towards tidying everything. :slight_smile:

The values you are using here:

are not the appropriate values. The UNITE tutorial I linked should help you with this.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.