Qiime2R-Not compatible with R version 3.1 or 3.5

Hello,

I have a quick question regarding qiime2r. I tried to install it on R 3.1 and it said that it is not available for that version, hence, I updated R, but I still get the same message.

install.packages("QIIME2R")
Warning in install.packages :
_ package ‘QIIME2R’ is not available (for R version 3.5.1_)

Do you have any suggestion of what I can do? If not, I could just work by exporting all data as a .tsv file, correct?

Hi @Fabs,

I’m pinging @jbisanz, the creator of that plugin for his feedback.

1 Like

Thank you, I will wait for his response.

The error message is a bit of a misnomer. It is actually telling you that it can not find a package called QIIME2R in CRAN. Broadly speaking, there are 3 repositories you will use to install packages for R: CRAN, Bioconductor, and Github. CRAN is the general repository for packages which is where install.packages() installs packages from by default. Bioconductor is where many bioinformatics tools are located and is where biocLite() pulls its packages from. Github is usually where the latest development versions of packages or new packages that have not yet gone into a major repository go (like qiime2R). To install from github, the easiest way is using devtools::install_github(). While I plan on submitting qiime2R to bioconductor, for now it is only available from github. You can install it as below:

install.packages("devtools") #if you don't have devtools installed
devtools::install_github("jbisanz/qiime2R")

With all that said, it does specify that your R version should be 3.5 or greater in the current version which is a bit artificial but what can I say, update your deal.

5 Likes

I see!

Perfect, I will install them with github. Thanks!

Hi Jbisanz,

Quick question. I do have Rstudio 3.5, and I used the code you mentioned to install the software, but, I still get the same error and in addition, I received this error.

devtools::install_github(“jbisanz/qiime2R”)
Skipping install of ‘qiime2R’ from a github remote, the SHA1 (ba443df0) has not changed since last install.
** Use force = TRUE to force installation**

Any ideas?

1 Like

This would actually suggest you have already installed the package. It is saying that it won’t update the package because it is identical to the one that is there. You should be able to load it now with library(qiime2R).

1 Like

Hi,
I have only the CRAN depository. I used the command as practice but not worked.

devtools::install_github(“jbisanz/qiime2R”)

Do you have an idea to install Qiime2R package in RStudio?
I am using the latest version of RStudio!

Thanks

Hi Meha,

(Confusingly) Rstudio is an interface to R and its version is unrelated to your R version. Download the latest version here for your operating system: https://www.r-project.org/. Then make sure you have also installed devtools. If it still does not work, please post the error message when you try to install.

Jordan

2 Likes

Hi @jbisanz
Thanks!
I followed by here.
https://cran.r-project.org/

The link you sent was confusing to install R. I could not handle it.
https://www.r-project.org/
https://cran.r-project.org/src/base/R-3/

The result is:

It appears that devtools is in the middle of installing in your screenshot. I do not see an error raised. The installation of tools that require compilation may not be instantaneous. It appears you have R 3.4.4 which should be supported.

A post was split to a new topic: qiime2R IRanges installation issue

Hello,

@jbisanz I am having difficulties in installing qiime2R on my version of R. I have tried -

install.packages("remotes")
library(remotes)
remotes::install_github("jbisanz/qiime2R")
library(qiime2R)

library(devtools)
devtools::install_github(jbisanz/qiime2R)

BiocManager::install("IRanges")
library(IRanges)
devtools::install_github("jbisanz/qiime2R")
library(qiime2R)

The main error message I am getting is this:

Warning message:
In i.p(...) :
installation of package ‘C:/Users/ashoo/AppData/Local/Temp/RtmpEhm8Bn/file567060197614/qiime2R_0.99.6.tar.gz’ had non-zero exit status

And generally this one when I try to load the library:

library(qiime2R)
Error in library(qiime2R) : there is no package called ‘qiime2R’

Any help you can offer would be highly appreciated, please and thank you.

Annalise