qiime2 artifact not found in dada2 denoising step (but present)

Hi,

I am experiencing the same issue as the guy in this thread:
Not a qiime2 artifact file error in Qiime2-2019.4).

  • I am also using 2019.4 (conda)

  • Trying to run
    qiime dada2 denoise-paired --i-demultiplexed-seqs all.qza --p-trim-left-f 40 --p-trim-left-r 20 --p-trunc-len-f 240 --p-trunc-len-r 220 --o-table table.qza --o-representative-sequences rep-seqs.qza --o-denoising-stats denoising-stats.qza

but get error message that all.qza is not a qiime2 artifact.
in the folder, all.qza is definitely present. I also checked with -ls that the file can be found. I also had a look at the visualization of all.qzv and it looks fine.

From the previous (closed) post above it seems this is a bug. I am a total newbie to bioinformatics and not sure how to continue now.
I went to https://github.com/qiime2/q2cli and downloaded the latest version but not sure how to incorporate that?

Any help would be greatly appreciated.

Good afternoon,

Thanks for posting your question. As far as I can tell, you are doing everything right. I would also check the path using ls and open up the .qzv file just like you did.

Would you feel comfortable posting the all.qza and all.qzv files? Maybe we can take a look to see what’s going on.

Colin

P.S. Were you able to run qiime dada2 denoise-paired using the data from the tutorial? It’s also possible that something went wrong during installation, and doing the tutorial is a great way to make sure your setup works.

Hi Colin, thanks for your response.
As I meanwhile managed to magically start running it but ran into more errors, I have another post going (error while running DADA2 in R (return code 1), all reads filtered.) so I think this thread can be closed? Thanks for your thoughts though! The problem seems to be something with the setup rather than my qza because when I run the tutorial data I get the same error message now than with my data:
PermissionError: [Errno 13] Permission denied: '/etc/sysconfig/clock’

Plugin error from dada2:

** [Errno 13] Permission denied: ‘/etc/sysconfig/clock’**

(qiime2-2019.4) [email protected]:~/qiime2-moving-pictures-tutorial> qiime dada2 denoise-single --i-demultiplexed-seqs demux.qza --p-trim-left 0 --p-trunc-len 120 --o-representative-sequences rep-seqs-dada2.qza --o-table table-dada2.qza --o-denoising-stats stats-dada2.qza --verbose
Running external command line application(s). This may print messages to stdout and/or stderr.
The command(s) being run are below. These commands cannot be manually re-run as they will depend on temporary files that no longer exist.

Command: run_dada_single.R /tmp/qiime2-archive-prx2uzes/99cf0944-0254-4510-95ae-029351285aa7/data /tmp/tmpevkficge/output.tsv.biom /tmp/tmpevkficge/track.tsv /tmp/tmpevkficge 120 0 2.0 2 Inf consensus 1.0 1 1000000 NULL 16

R version 3.5.1 (2018-07-02)
Loading required package: Rcpp
DADA2: 1.10.0 / Rcpp: 1.0.1 / RcppParallel: 4.4.2

  1. Filtering …
  2. Learning Error Rates
    19539480 total bases in 162829 reads from 34 samples will be used for learning the error rates.
  3. Denoise samples …
  4. Remove chimeras (method = consensus)
  5. Report read numbers through the pipeline
  6. Write output
    Traceback (most recent call last):
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/q2cli/commands.py”, line 311, in call
    results = action(**arguments)
    File “</home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/decorator.py:decorator-gen-449>”, line 2, in denoise_single
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 231, in bound_callable
    output_types, provenance)
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 393, in callable_executor
    spec.qiime_type, output_view, spec.view_type, prov)
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/sdk/result.py”, line 271, in _from_view
    provenance_capture=provenance_capture)
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/core/archive/archiver.py”, line 316, in from_data
    Format.write(rec, type, format, data_initializer, provenance_capture)
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/core/archive/format/v5.py”, line 21, in write
    provenance_capture)
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/core/archive/format/v1.py”, line 26, in write
    prov_dir, [root / cls.METADATA_FILE, archive_record.version_fp])
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/core/archive/provenance.py”, line 312, in finalize
    self.write_action_yaml()
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/core/archive/provenance.py”, line 289, in write_action_yaml
    fh.write(yaml.dump({‘execution’: self.make_execution_section()},
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/core/archive/provenance.py”, line 255, in make_execution_section
    runtime[‘start’] = start = self._ts_to_date(self.start)
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/qiime2/core/archive/provenance.py”, line 249, in _ts_to_date
    return datetime.fromtimestamp(ts, tzlocal.get_localzone())
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/tzlocal/unix.py”, line 131, in get_localzone
    _cache_tz = _get_localzone()
    File “/home/n9606661/miniconda3/envs/qiime2-2019.4/lib/python3.6/site-packages/tzlocal/unix.py”, line 85, in _get_localzone
    with open(tzpath, ‘rt’) as tzfile:
    PermissionError: [Errno 13] Permission denied: '/etc/sysconfig/clock’

Plugin error from dada2:

** [Errno 13] Permission denied: ‘/etc/sysconfig/clock’**

Yikes! Do you have a sysadmin you can check with about this? QIIME 2 is trying to get your local timezone to record the timestamp in provenance, but your system appears to have locked down the timezone setting file, which is a bit atypical — most linux systems will expose this file as read-only:

ls -lah /etc/sysconfig/clock
-rw-r--r-- 1 root root 30 Jun 10 11:45 /etc/sysconfig/clock

Let us know what your sysadmin says, I suspect this file’s permission issue is going to cause problems well outside of QIIME 2, so they would probably appreciate a head’s up about this.

:qiime2: :t_rex:

They think its something in the python script? I got a temporary cluster, so just a workaround but not a fix unfortunately!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.