Not a qiime2 artifact file error in Qiime2-2019.4

Dear Friends,
I ran this below denoising command and got below error. The qzv files are attached:

Ionexpress_1to11_single-end-demux.qzv: imported single-end ion torrent DNA sequenced data.
Ionexpress_1to11_single-end-demux-trimmed-12.qzv: primers trimmed file
Ionexpress_1to11_single-end-demux.qzv (289.4 KB)
Ionexpress_1to11_single-end-demux-trimmed-12.qzv (345.2 KB)

Command and error:

qiime dada2 denoise-single --i-demultiplexed-seqs Ionexpress_1to11_single-end-demux.trimmed-12.qza --p-trim-left 0 --p-trunc-len 301 --o-representative-sequences Ionexpress_1to11_dada2-rep-seqs.qza --o-table Ionexpress_1to11-dada2-rep-seqs-table.qza --o-denoising-stats Ionexpress_1to11_dada2-rep-seqs-stats-dada2.qza --verbose

Usage: qiime dada2 denoise-single [OPTIONS]

This method denoises single-end sequences, dereplicates them, and filters

--i-demultiplexed-seqs ARTIFACT SampleData[SequencesWithQuality |
The single-end demultiplexed sequences to be
denoised. [required]
--p-trunc-len INTEGER Position at which sequences should be truncated due
to decrease in quality. This truncates the 3' end of
the of the input sequences, which will be the bases
that were sequenced in the last cycles. Reads that
are shorter than this value will be discarded. If 0
is provided, no truncation or length filtering will
be performed [required]
--p-trim-left INTEGER Position at which sequences should be trimmed due to
low quality. This trims the 5' end of the of the
input sequences, which will be the bases that were
sequenced in the first cycles. [default: 0]
--p-max-ee NUMBER Reads with number of expected errors higher than
this value will be discarded. [default: 2.0]
--p-trunc-q INTEGER Reads are truncated at the first instance of a
quality score less than or equal to this value. If
the resulting read is then shorter than trunc-len,
it is discarded. [default: 2]
--p-chimera-method TEXT Choices('pooled', 'none', 'consensus')
The method used to remove chimeras. "none": No
chimera removal is performed. "pooled": All reads are
pooled prior to chimera detection. "consensus":
Chimeras are detected in samples individually, and
sequences found chimeric in a sufficient fraction of
samples are removed. [default: 'consensus']
--p-min-fold-parent-over-abundance NUMBER
The minimum abundance of potential parents of a
sequence being tested as chimeric, expressed as a
fold-change versus the abundance of the sequence
being tested. Values should be greater than or equal
to 1 (i.e. parents should be more abundant than the
sequence being tested). This parameter has no effect
if chimera-method is "none". [default: 1.0]
--p-n-threads INTEGER The number of threads to use for multithreaded
processing. If 0 is provided, all available cores
will be used. [default: 1]
--p-n-reads-learn INTEGER
The number of reads to use when training the error
model. Smaller numbers will result in a shorter run
time but a less reliable error model.
[default: 1000000]
--p-hashed-feature-ids / --p-no-hashed-feature-ids
If true, the feature ids in the resulting table will
be presented as hashes of the sequences defining each
feature. The hash will always be the same for the
same sequence so this allows feature tables to be
merged across runs of this method. You should only
merge tables if the exact same parameters are used
for each run. [default: True]
--o-table ARTIFACT FeatureTable[Frequency]
The resulting feature table. [required]
--o-representative-sequences ARTIFACT FeatureData[Sequence]
The resulting feature sequences. Each feature in the
feature table will be represented by exactly one
sequence. [required]
--o-denoising-stats ARTIFACT SampleData[DADA2Stats]
--output-dir PATH Output unspecified results to a directory
--verbose / --quiet Display verbose output to stdout and/or stderr
during execution of this action. Or silence output if
execution is successful (silence is golden).
--citations Show citations and exit.
--help Show this message and exit.

                There was a problem with the command:                     

(1/1) Invalid value for "--i-demultiplexed-seqs": 'Ionexpress_1to11_single-
end-demux.trimmed-12.qza' is not a QIIME 2 Artifact (.qza)

Please let me know how to solve this issue? Thanks much!

Hi @danielsebas,

The most likely situation is that this file does not exist at all (a typo in the path perhaps, make sure tab-completion is finding it). The error message is an unfortunate side-effect of the refactor that happened in 2019.4. @Oddant1 fixed this for the next release, so it shouldn’t be an issue in the future.

Sorry for the trouble!

Thanks @ebolyen. The file is certainly there in the folder. Can you please let me know how this issue can be solved? I am using the latest qiime2 release from the website of Qiime2. Thanks! I would really appreciate @thermokarst comments too on solving this issue. Thanks much!

I don't have anything else to offer besides what @ebolyen said. Carefully double-check spelling, path, etc. QIIME 2 is not able to find a usable Artifact with that exact name in that exact location (keep in mind, computers aren't clever, they will only do exactly what you tell them to do).


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.