qiime feature-classifier classify-sklearn Missing option

Hello to all the community

I am performing bacterial microbiome analysis of pigeon fecal matter sequences using the Qiime program. I am using qiime2 with linux as windows subsystem and WSL2-Ubuntu-22.04

At this moment I am running the command to test the classifier, which is the following

qiime feature-classifier classify-sklearn
--i-classifier classifier2040.qza \
--i-reads rep-seqs-dada2.qza
--o-classification taxonomy2040.qza

qiime metadata tabulate
--m-input-file taxonomy2040.qza
--o-visualization taxonomy2040.qzv

image

When I run it it gives me the following problem:

image

I don't understand what could be happening or if I have made a mistake before that this problem appears. If someone can please guide me on what I'm doing wrong, I would really appreciate it.

Hello!
Could you check if there are no spaces after each backslash in the same line?

1 Like

Hello and thank you very much for helping me.

I checked and noticed that one of the command lines had a space and I already corrected it. For now it seems to be running without a problem.

Hello timanix, thank you very much for your advice. The truth is I didn't know that a small space after the diagonal line could cause errors. Thank you very much, I will be more attentive.

1 Like

I didn't know it as well until I put one there and encountered the same error =).

1 Like