QIIME 2 Studio feature-classifier BAD REQUEST - <class 'qiime2.core.type.grammar.UnionExp'>

Dear Forum,

Oracle VM VirtualBox 6.1.14 r140239 (Qt5.6.2)
QIIME 2 Studio (Qiime2 core 2020.8)

first of all i would like to thank everyone involved in the development and support at qiime. It has become a powerful tool and qiime 2 studio also offers "friends of clicking" a way to use it.

My goal is to evaluate 2000 amplicon samples (V3,V4). Unfortunately the instructions are not very comprehensive for q studio. Therefore I needed some time until I could generate the data to an artifact. That still worked now.

The reference data for the taxonomy would be similarly cumbersome, but I was able to load the RDP 18 (Taxonomic reference data) set. (took longer than necessary because Qiime only accepts capital letters in the sequences).

Now my current problem: With the feature classifier I want to trim the reference data to the required length of the V3-V4 (Extracts reads from reference sequences). Afterwards train the dataset with my sample data and then identify my ASVs.
Unfortunately I get the error
"BAD REQUEST - <class 'qiime2.core.type.grammar.UnionExp'> object has no attribute 'decode'"
In the forum was spoken of a bug, but no solution addressed. I also get the same error with VSEARCH-based consensus taxonomy classifier. BLAST+ consensus taxonomy classifier generates an artifact.

Maybe I took a wrong turn in the preliminary work. I would be grateful for some advice.

All the best


Unfortunately this is known bug in q2studio. You will have to run this particular step with q2cli for right now, though the rest of the analysis can be completed in q2studio.

Thank you for confirming my fear. I had hoped that the bug was fixed in the last months. Then I will have to do this step "externally" with q2cli.

Is there then still a support and further development of Q2 Studio? Then I would have a list of bugs and wishes for more user friendliness. Or is the Studio variant of Qiime 2 only a trial and will be permanently shut down?

There has been a bit of work done towards this particular bug, though we were not able to include a satisfactory fix in the 2021.8 release. That being said, there is going to be very little further development on QIIME 2 Studio, as it was a prototype and we are currently focusing on q2galaxy, which should ultimately lead to a much better GUI experience!


thank you for your honesty. Basically, it is also understandable that it is better to calculate via the Galaxy infrastructure. For the usual PC systems, some calculations are simply too much.
It's a pity, though, because users are usually more careful on their own PCs than in the cloud. Which inevitably leads to data garbage and useless calculations (power consumption). I'm not an eco warrior, but the data centers are probably not heated with renewable electricity.

Thank you for your work!

1 Like


That is a valid concern! While there is a Galaxy public cloud, the q2galaxy interface is really more meant for a local/individual install. Check out this video for a look at q2galaxy!


Also I realized I should clarify, the long term goal is not to have local/individual installs. What we really want to do is to enable the creation of private instances, such as those hosted on a university's or lab groups high power computing cluster. In its current alpha state, q2galaxy is not really ready to be deployed this way and so a local/individual machine install is the best way to go about using it for now. Hopefully this is something we can get to soon!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.