Plugin error from demux

I am struggling with importing paired-end sequence files.
I tried importing my (demultiplexed) paired-end Miseq files and got the output file named ‘paired-end-demux.qza’.
After that I tried [qiime demux summarize] but got an error.
Anybody knows what went wrong here :frowning:

qiime tools import --type ‘SampleData[PairedEndSequencesWithQuality]’ --input-path Manifest.csv --output-path paired-end-demux.qza --source-format PairedEndFastqManifestPhred64

qiime demux summarize --i-data paired-end-demux.qza --o-visualization demux.qzv
Plugin error from demux:

Compressed file ended before the end-of-stream marker was reached

Debug info has been saved to /var/folders/vh/l4ckn9311hx8yrvvbfpnh6zh0000gn/T/qiime2-q2cli-err-kjhzmaq1.log

qiime tools peek paired-end-demux.qza
UUID: 53743d83-7f36-40e8-9029-450453314b27
Type: SampleData[PairedEndSequencesWithQuality]
Data format: SingleLanePerSamplePairedEndFastqDirFmt

Hello Jeongsu,

Thanks for posting the full command and error. Can you post that .log file too?

I’m guessing the key part of the error is:
Compressed file ended before the end-of-stream marker was reached
This makes me think the file did not finish downloading or was corrupted in some way. But that log file should tell us more.

Thanks,
Colin

Thanks for the help @colinbrislawn!

This error has come up many times on the forum, and it usually indicates that the .fastq.gz files that were initially imported are corrupted somehow. @Jeongsu_Kim, can you try re-importing the .fastq.gz files and rerunning qiime demux summarize? If that doesn’t solve the issue, it’s likely that your FASTQ files are corrupted (which QIIME 2 isn’t able to fix), so you’ll need to check each .fastq.gz file to make sure that they are valid gzipped files. As @colinbrislawn mentioned, the files may have been corrupted while downloading or transferring to your computer, so I’d try re-downloading them first to see if that was the issue.

Another question, which is likely unrelated to this specific problem: are you certain that the FASTQ files have PHRED 64 quality scores? Most Illumina data these days use PHRED 33; I rarely see PHRED 64 data unless it was generated a few years ago. If you choose the wrong PHRED offset, the quality scores won’t be interpreted correctly and will throw off your analyses.

Problem solved after I re-imported the fastq files.
Thank you so much for your help!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.