Issue with my dad2 denoise-paired command script

I tried to use the dada2 denoise-paired command in qiime2 in order to truncate the forward and reverse sequences of a single sample, both of which I had already removed the primers using the cutadapt trim-paired command. I viewed the quality of both sequences in qiime 2 (please click on the link to the file here - Dropbox - Dolichospermum-spp-number1-IGK_S15_L001_R1_001.fastq.gz - Simplify your life). It appeared that the median quality of the reverse sequences appeared to drop off after the 290th sequence (<20), so I decided to truncate the forward and reverse sequences at this sequence using the following command:

qiime dada2 denoise-paired
--i-demultiplexed-seqs /home/qiime2/Desktop/Dolichospermum/trim.qza
--p-trunc-len-f 290
--p-trunc-len-r 290
--o-table /home/qiime2/Desktop/Dolichospermum/trim.qza/table.qza
--o-representative-sequences /home/qiime2/Desktop/Dolichospermum/trim.qza/rep-seqs.qza
--o-denoising-stats /home/qiime2/Desktop/Dolichospermum/trim.qza/denoising-stats.qza

But the subsequent error(s) resulted:

  1. 290 total bases in 1 read that something is wrong with the truncate command
  2. 290 total bases in 1 read that something is wrong with the truncate command

However, when I replace "290" with "0" in the dada2 denoise-paired command script above, the code successfully runs, replacing the above error with this:

  1. Has 12129464 total bases in 44642 reads
  2. Has 12264428 total bases in 44642 reads

Any advice/recommendation as to why this might be happening would be greatly appreciated. And please let me know if you have trouble accessing the link. Thank you!!

Hello Benjamin,

Can you post a screenshot of your read quality and also your denoising-stats.qza file? I think I know what's going on, but I wanted to take a look at the graphs to make sure. :mag_right:

Hi Colin,

Sorry for the delay. Attached are pics of the forward and reverse reads and my zipped denoising-stats-qza file. Please let me know if you need anything else.

Ben

denoising-stats.qza (15.6 KB)

1 Like

Thanks for posting those graphs!

While those graphs show your reads going all the way out to 300 bp, this error claims otherwise.

According to that error, only 1 read is >290 bp long, so trimming at this length does not make much sense. Not trimming at all by passing 0 addresses this issue.

You could try trimming at a happy medium, say 260 on the forward and 220 on the reverse, in order to remove low quality data and still get reads to join.

Let me know what you find!