Importing paired-end de-multiplexed fastq files into qiime2 as .qza artifact

Hello, I have been running into many errors with importing paired-end de-multiplexed fastq.gz files as .qza artifacts.

My files are multiple forward and reverse sequences, all in one directory called demultiplexed_read/.
For example: demultiplex_reads/F9B4_6-TCCGTTCG-CATTAAGG-R1.fastq.gz
demultiplex_reads/F9B4_6-TCCGTTCG-CATTAAGG-R2.fastq.gz

The issue is I do NOT have a metadata file, nor barcode information.

I have tried numerous methods listed in https://docs.qiime2.org/2020.2/tutorials/importing/#fastq-manifest-formats, as well as trial and error while trying different --type- and --input-format

I am running on (qiime2-2020.2), installed via Miniconda3, on a Linux bash shell.

I am often getting an error saying my directory is not a file, or that there are errors in the file. Ex:

qiime tools import --type PairedEndSequences --input-path demultiplex_reads/ --output-path paired_demux.qza
Traceback (most recent call last):
File “/home/nsaeedch/miniconda3/envs/qiime2-2020.2/lib/python3.6/site-packages/q2cli/builtin/tools.py”, line 158, in import_data

  • view_type=input_format)*
  • File “/home/nsaeedch/miniconda3/envs/qiime2-2020.2/lib/python3.6/site-packages/qiime2/sdk/result.py”, line 213, in import_data*
  • output_dir_fmt = pm.get_directory_format(type_)*
  • File “/home/nsaeedch/miniconda3/envs/qiime2-2020.2/lib/python3.6/site-packages/qiime2/sdk/plugin_manager.py”, line 313, in get_directory_format*
  • % semantic_type)*
    TypeError: Semantic type PairedEndSequences does not have a compatible directory format.

An unexpected error has occurred:

  • Semantic type PairedEndSequences does not have a compatible directory format.*

See above for debug info.

Not exactly how to import this data, I want to utilize it for the dada2, but need it in the .qza format.

Hi!

Cant help you with those error codes but…

Wich import metods have you tried?

If you dont have a metadata file, you can make it, its quite easy and the tutorials have an example, you can use that file and modify it to your needs.

if you dont have barcodes, try the Manifest Import metod :smiley: its super easy.

1 Like

So I did actually manage to import my daya, I was missing a manifest file, so I made a tab-delimited manifest file and successfully outputted to paired-end-demux.qza.

I am now trying to conduct dada2 using this script:

qiime dada2 denoise-paired --i-demultiplexed-seqs paired-end-demux.qza --p-trunc-len-f 244 --p-trunc-len-r 200 --output-dir dada2_output/

But I am receiving this error message:

Plugin error from dada2:

No reads passed the filter. trunc_len_f (244) or trunc_len_r (200) may be individually longer than read lengths, or trunc_len_f + trunc_len_r may be shorter than the length of the amplicon + 12 nucleotides (the length of the overlap). Alternatively, other arguments (such as max_ee or trunc_q) may be preventing reads from passing the filter.

Debug info has been saved to /home/nsaeedch/FinalProject/DemultiplexReads/qiime2-q2cli-err-8jk9i2tk.log

Any suggestions?

Welcome to the forum @noor_uto!

Glad you got the import issue sorted out; we will assist you with your dada2 issue in this separate topic:


(thanks for opening your new question in a separate topic, but please do not cross-post as you have done here. Thanks!)

No worries, I will not!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.