Import data problem

Hi,
I am totally new and illiterate in bioinformatic and the past few days where I played with qiime2 made me question my life choices of doing a master in microbiome, but I’ll try again I guess :wink:

So I am running the 2020.11 version of qiime2 on conda (Ubuntu 20.04 LTS) and I did most of the tutorials in qiime2 and it worked perfectly. Now, when I am trying to play with my own data I can’t even pass the import data step (and that’s a bummer). Basically I have a file on my desktop name ‘‘Projetmain’’ containing my demultiplexed paired-end sequences (2 fastq files per sample). I tried multiple commands:

1- qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path C:\Users\audre\Bureau\Projetmain
–input-format CasavaOneEightSingleLanePerSampleDirFmt
–output-path demux-paired-end.qza

2- qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path Users\audre\Bureau\Projetmain
–input-format CasavaOneEightSingleLanePerSampleDirFmt
–output-path demux-paired-end.qza

3- qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path Users\audre\Bureau\Projetmain
–output-path demux-paired-end.qza

etc, etc, etc,

But I always have the same error message:
There was a problem with the command:
(1/1) Invalid value for ‘–input-path’: Path ‘UsersaudreBureauProjetmain’
does not exist.

I tried to write command with ‘’–verbose’’, but I don’t think I used it right because it said:
There was a problem with the command:
(1/1?) no such option: --verbose

The ‘‘import data’’ page doesn’t explain really how to import from my computer, it just says to download from the site to follow the exemple and doesn’t explain why they put what they put in their example of command lines (As I said I am illiterate and have the same capacities in computer than a 10 year old right now haha). People in the forum have definitely better understanding than me because their importation data problems seem more problematic than mine and I sadly spent multiple hours try to fix this, probably very simple, problem. So I really need your help!

Thank you soooooooo much!

1 Like

Hi, double check the path you are providing to your reads you want to import. Looks like you did it not correctly (for example, “C:” , “”.) Try to cd in terminal to you reads and check the path, how it is written in terminal

Hi @Audrey_Anne,

I think you are trying to use Windows command prompt syntax in your Ubuntu LTS.

That is, this:
Users\audre\Bureau\Projetmain

should be:
Users/audre/Bureau/Projetmain

One trick that you can use to share files between your Windows and Ubuntu LTS is to do the following:

  1. In Ubuntu LTS terminal window type: explorer.exe . . This will open a Windows Explorer window with the path to your home directory within your Ubuntu LTS. See here.
  2. Drag this path in the window to your Quick access list.
  3. Now you can drag/drop files into this folder so that it is easily accessible within your Ubuntu LTS.
  4. Make sure to use forward-slashes and not backward-slashes as above.
  5. Type pwd to see your current working directory within Ubuntu LTS.

-Hope this helps!
-Mike

2 Likes

Hi,

So nice to see someone who dare to struggle with the bioinformatic pipelines. You are almost there, Keep trying.

Regarding your data import issue, as far as i am able to understand you are trying to set the path of a folder in Linux environment but that folder is not in Linux environment yet.

Simplest method is creating a shared folder that will act as a sort of bridge between host (Windows machine) and the guest (Virtual machine i.e., QIIME) environments.

Check out this video for setting a shared folder: https://youtu.be/eOLL-qSbv8Y

Bring you data to the shared folder and then set its path.

Good luck

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.