Filtering rep.qza based on filtered feature table

Hello,

I’ve filtered my raw feature table and passed it to the new “filter-seqs” functon, trying to exclude representative sequences not present in the filtered feature table. However, I got an error message saying:

“There was an issue with viewing the artifact table-no-chlo-mito-lowPre-conta-with-Phyla.qza as metadata: Artifact has no metadata.”

The commands I used were:

qiime feature-table filter-seqs
–i-data rep-seqs.qza
–m-metadata-file table-no-chlo-mito-lowPre-conta-with-Phyla.qza
–p-no-exclude-ids
–o-filtered-data rep-seqs-filtered.qza

How can I make it work in QIIME2 2017.10? Do I still need to make a tsv file from the filtered feature table as dememstrated in this forum post?

1 Like

Hi @yanxianl!

Unfortunately, I think this is the best option right now, if using q2cli (there are shorter options if using the Artifact API, but if you haven’t worked with that yet, it might be more difficult than the cli).

We have an open issue to track the development of a convenience method for this type of filtering — we will update this post when that becomes available, but in the meantime, the procedure outlined here (the post you linked to above) is your best bet.

Let us know if you get stuck or have any questions! :t_rex:

Hi @thermokarst,

I’ve tried the method you suggested in that post and it worked !

Thanks a lot!

In the new QIIME 2 2017.12 release you can provide a feature-table to feature-table filter-seqs to remove sequences that do not have corresponding IDs in the table!

3 Likes