feature-classifier not producing an output

Hello, I have a problem with the feature classifier.
So I tried this on multiple computers (with intel and AMD chips) and with multiple versions of QIIME2 (QIIME2 2023.5 and 2023.7)
So I have a dual boot on my computer with Windows and Linux Ubuntu, newest release. It has 16 GB of RAM. I installed QIIME2 natively on Linux in a conda environment. I tried it on another computer with a virtual box and on a third one with a virtual box as well.
I tried the following commands:
!qiime feature-classifier fit-classifier-naive-bayes
--i-reference-reads silva-138-99-seqs.qza
--i-reference-taxonomy silva-138-99-tax.qza
--o-classifier self-trained-classifier.qza
Here I got this output:
/home/shokuhinkagakusha/miniconda3/envs/qiime2-2023.7/lib/python3.8/site-packages/q2_feature_classifier/classifier.py:102: UserWarning: The TaxonomicClassifier artifact that results from this method was trained using scikit-learn version 0.24.1. It cannot be used with other versions of scikit-learn. (While the classifier may complete successfully, the results will be unreliable.) warnings.warn(warning, UserWarning)
I read in suggestions online that the best might be to delete and reinstall the conda environment and I did just that.
For these I got 0 output:
!qiime feature-classifier classify-sklearn
--i-reads bacterial-rep-seqs.qza
--i-classifier 515f-806r-animal-distal-gut-classifier.qza
--o-classification bacterial-bespoke-taxonomy.qza

!qiime feature-classifier classify-consensus-blast
--i-query bacterial-rep-seqs.qza
--i-reference-reads silva-138-99-seqs.qza
--i-reference-taxonomy silva-138-99-tax.qza
--o-classification bacterial-blast-taxonomy.qza
--o-search-results bacterial-taxonomy-blast-search-results.qza

!qiime feature-classifier classify-consensus-vsearch
--i-query bacterial-rep-seqs.qza
--i-reference-reads silva-138-99-seqs.qza
--i-reference-taxonomy silva-138-99-tax.qza
--o-classification bacterial-vsearch-taxonomy.qza
--o-search-results bacterial-vsearch-taxonomy-search-results.qza

They all say they ran in my jupyter lab but I get no output.
I can share the image of a later attempt with the older QIIME2 version.

For some reason I don't get any output with anything that involves the feature classifier.
Everything else worked fine, even resource intensive steps like DADA2. I don't get an error message as you can see.

Does anyone have an idea what the problem could be?

Hi @lwcoding!
I was able to find a few other instances of this error by searching the forum. Give those suggestions a try. Please let me know if you are continuing to get no output on the other blocks, but I am hopeful that fixing this error will resolve the rest.



This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.