error when running 'biom convert'

Hello Nicholas
I am Sorry, as I know this is not the right page to post this type of question over here. however i am in a fix and not able to get this command biom convert.
While using the command
convert biom -i otu/otu_table.biom -o otu_table.txt --to-tsv --header-key taxonomy.
The command shows error
Please suggest here

Hi! Could you try

biom convert -i otu/otu_table.biom -o otu_table.tsv --to-tsv

Hello timanix
I tried the commoand biom convert -i otu/otu_table.biom -o otu_table.tsv --to-tsv
but error
Traceback (most recent call last):
File “/usr/local/bin/pyqi”, line 184, in
optparse_main(cmd_obj, argv[1:])
File “/usr/local/lib/python2.7/dist-packages/pyqi/core/interfaces/optparse/”, line 275, in optparse_main
result = optparse_cmd(local_argv[1:])
File “/usr/local/lib/python2.7/dist-packages/pyqi/core/”, line 39, in call
cmd_result = self.CmdInstance(**cmd_input)
File “/usr/local/lib/python2.7/dist-packages/pyqi/core/”, line 137, in call
result =**kwargs)
File “/usr/local/lib/python2.7/dist-packages/biom/commands/”, line 149, in run
raise CommandError(“Must specify --table-type!”)
pyqi.core.exception.CommandError: Must specify --table-type!
please suggest full command.

That’s strange. Just run this command with my data and it’s worked.

biom convert -i Biom/feature-table.biom -o Biom/feature-table.tsv --to-tsv

If you will provide the files I will try on my machine and at least we will know if problem in the soft or in the file.
BTW, how you received a .biom table?

Hi timanix
Here it is otu_table.biom (690.2 KB)

Secondly please suggest how can i import this biom table in Qiime 2

Hi again
The same commands I wrote earlier worked

biom convert -i otu_table.biom -o otu_table.tsv --to-tsv

otu_table.tsv (75.8 KB)

If you are going to convert a .tsv back to .biom:

biom convert -i feature-table.tsv -o feature-table.biom --table-type="OTU table" --to-hdf5

And if you want to import a .biom to Qiime2:

qiime tools import \
    --input-path feature-table.biom \
    --type 'FeatureTable[Frequency]' \
    --input-format BIOMV210Format \
    --output-path table.qza
1 Like

Hello I am facing the same problem