Error in `qiime dada2 plot-qualities` related to incomplete installation

I run qiime2 on remote server and jupyter notebook. But there are plenty of error in each step.

Hi @yech1990, sorry to hear you are having problems. There shouldn’t be any problems running QIIME 2 remotely via jupyter (we know of at least a few users that are running qiime2 in this way) - can you please provide some additional details about how you have installed jupyter, qiime2, and an example of what kind of errors it is that you are seeing? Thanks!

1 Like

hi @thermokarst
I run the “Moving Pictures” tutorial in jupyter notebook using my own data as input.
The data is generate by qiime2, which is the output of and

I even can't the pass the step of quality control.

Can you show me some examples in Jupyter notebook.
This the sampled data of my input.
raw-sequences.qza (91.5 KB)

I run conda install -c r 'r-base=3.3.1 1', but the error still occur.

I work on Jupyter notebook environment though remote access.

the verbose log:

Traceback (most recent call last):
  File ".anaconda3/envs/qiime2/bin/qiime", line 6, in <module>
  File ".anaconda3/envs/qiime2/lib/python3.5/site-packages/click/", line 716, in __call__
    return self.main(*args, **kwargs)
  File ".anaconda3/envs/qiime2/lib/python3.5/site-packages/click/", line 696, in main
    rv = self.invoke(ctx)
  File ".anaconda3/envs/qiime2/lib/python3.5/site-packages/click/", line 1060, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File ".anaconda3/envs/qiime2/lib/python3.5/site-packages/click/", line 1060, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File ".anaconda3/envs/qiime2/lib/python3.5/site-packages/click/", line 889, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File ".anaconda3/envs/qiime2/lib/python3.5/site-packages/click/", line 534, in invoke
    return callback(*args, **kwargs)
  File ".anaconda3/envs/qiime2/lib/python3.5/site-packages/q2cli-0.0.6-py3.5.egg/q2cli/", line 210, in __call__
  File "<decorator-gen-138>", line 2, in plot_qualities
  File ".anaconda3/envs/qiime2/lib/python3.5/site-packages/qiime-2.0.6-py3.5.egg/qiime/core/", line 227, in callable_wrapper
    output_types, provenance)
  File ".anaconda3/envs/qiime2/lib/python3.5/site-packages/qiime-2.0.6-py3.5.egg/qiime/core/", line 426, in _callable_executor_
    ret_val = callable(output_dir=temp_dir, **view_args)
  File ".anaconda3/envs/qiime2/lib/python3.5/site-packages/q2_dada2-0.0.6-py3.5.egg/q2_dada2/", line 61, in plot_qualities
  File ".anaconda3/envs/qiime2/lib/python3.5/site-packages/q2_dada2-0.0.6-py3.5.egg/q2_dada2/", line 29, in run_commands
  File ".anaconda3/envs/qiime2/lib/python3.5/", line 708, in run
    output=stdout, stderr=stderr)

ubprocess.CalledProcessError: Command '['profile_quality.R', '/tmp/qiime2-archive-8hmf8o42/5a615422-475d-4c83-aea3-3c76d18c4ad6/data/F0156_43_L001_R1_001.fastq.gz', '/tmp/qiime2-temp-5da50ha2']' returned non-zero exit status 1

Hi @yech1990,

Could you run conda list --show-channel-urls?

Also the output looks to be just the python traceback, since you say you are in a Jupyter Notebook environment was there any other output? If not you can use:

from qiime.util import redirected_stdio

with open('stdout.log', 'w') as stdout, open('stderr.log', 'w') as stderr:
    with redirected_stdio(stdout=stdout, stderr=stderr):
        <your qiime API call here>

What are the contents of stdout.log and stderr.log (you can change these paths)?

1 Like

conda list output

# packages in environment at /home/yc/.anaconda3/envs/qiime2:
_nb_ext_conf              0.3.0                    py35_0
anaconda-client           1.6.0                    py35_0
arrow                     0.8.0                    py35_0    qiime2
binaryornot               0.3.0                0_ge797740    qiime2
biom-format               2.1.5                    py35_3    qiime2
bokeh                     0.12.3                   py35_0
bzip2                     1.0.6                         3
cachecontrol              0.11.7                   py35_0
cairo                     1.14.6                        0
click                     6.6                      py35_0
clyent                    1.2.2                    py35_0
cookiecutter              1.4.0                    py35_0    qiime2
curl                      7.49.0                        1
cycler                    0.10.0                   py35_0
dbus                      1.10.10                       0
decorator                 4.0.10                   py35_1
emperor                   1.0.0beta5               py35_2    conda-forge
entrypoints               0.2.2                    py35_0
expat                     2.1.0                         0
fontconfig                2.12.1                        0
freetype                  2.5.5                         1
future                    0.16.0                   py35_0
glib                      2.50.2                        0
gsl                       2.2.1                         0
gst-plugins-base          1.8.0                         0
gstreamer                 1.8.0                         0
h5py                      2.6.0               np111py35_2
harfbuzz                  0.9.39                        1
hdf5                      1.8.17                        1
icu                       54.1                          0
ijson                     2.3                      py35_0    qiime2
ipykernel                 4.5.2                    py35_0
ipymd                     0.1.2                    py35_0    qiime2
ipython                   5.1.0                    py35_0
ipython_genutils          0.1.0                    py35_0
ipywidgets                5.2.2                    py35_0
jbig                      2.1                           0
jinja2                    2.8                      py35_1
jinja2-time               0.2.0                    py35_0    qiime2
jpeg                      8d                            2
jsonschema                2.5.1                    py35_0
jupyter                   1.0.0                    py35_3
jupyter_client            4.4.0                    py35_0
jupyter_console           5.0.0                    py35_0
jupyter_core              4.2.1                    py35_0
libffi                    3.2.1                         1
libgcc                    5.2.0                         0
libgfortran               3.0.0                         1
libiconv                  1.14                          0
libpng                    1.6.22                        0
libsodium                 1.0.10                        0
libtiff                   4.0.6                         2
libxcb                    1.12                          1
libxml2                   2.9.4                         0
lockfile                  0.12.2                   py35_0
markupsafe                0.23                     py35_2
matplotlib                1.5.1               np111py35_0
mistune                   0.7.3                    py35_0
mkl                       11.3.3                        0
natsort                   5.0.1                    py35_0
nb_anacondacloud          1.2.0                    py35_0
nb_conda                  2.0.0                    py35_0
nb_conda_kernels          2.0.0                    py35_0
nbconvert                 4.2.0                    py35_0
nbformat                  4.2.0                    py35_0
nbpresent                 3.0.2                    py35_0
ncurses                   5.9                          10
nose                      1.3.7                    py35_1
notebook                  4.3.0                    py35_0
numpy                     1.11.2                   py35_0
openssl                   1.0.2j                        0
pandas                    0.19.1              np111py35_0
pango                     1.40.3                        0                   8.2.1                    py35_0
patsy                     0.4.1                    py35_0
pcre                      8.39                          1
pexpect                   4.0.1                    py35_0
pickleshare               0.7.4                    py35_0
pip                       9.0.1                    py35_1
pixman                    0.34.0                        0
poyo                      0.4.0                    py35_0    qiime2
prompt_toolkit            1.0.9                    py35_0
ptyprocess                0.5.1                    py35_0
pygments                  2.1.3                    py35_0
pyparsing                 2.1.4                    py35_0
pyqt                      4.11.4                   py35_4
python                    3.5.2                         0
python-dateutil           2.6.0                    py35_0
python-frontmatter        0.2.1                    py35_0    qiime2
pytz                      2016.10                  py35_0
pyyaml                    3.12                     py35_0
pyzmq                     16.0.2                   py35_0
q2-alignment              0.0.6                    py35_0    qiime2
q2-composition            0.0.6                    py35_0    qiime2
q2-dada2                  0.0.6                    py35_0    qiime2
q2-demux                  0.0.6                    py35_0    qiime2
q2-diversity              0.0.6                    py35_0    qiime2
q2-emperor                0.0.6                    py35_0    qiime2
q2-feature-classifier     0.0.6                    py35_0    qiime2
q2-feature-table          0.0.6                    py35_0    qiime2
q2-phylogeny              0.0.6                    py35_0    qiime2
q2-taxa                   0.0.6                    py35_0    qiime2
q2-types                  0.0.6                    py35_0    qiime2
q2cli                     0.0.6                    py35_0    qiime2
q2templates               0.0.6                    py35_0    qiime2
qiime                     2.0.6                    py35_0    qiime2
qt                        4.8.7                         4
qtconsole                 4.2.1                    py35_0
r-base                    3.3.1                         1    r
readline                  6.2                           2
requests                  2.12.4                   py35_0
scikit-bio                0.5.0               np111py35_0
scikit-learn              0.18.1              np111py35_0
scipy                     0.18.1              np111py35_0
seaborn                   0.7.1                    py35_0
setuptools                27.2.0                   py35_0
simplegeneric             0.8.1                    py35_1
sip                       4.18                     py35_0
six                       1.10.0                   py35_0
sqlite                    3.13.0                        0
statsmodels               0.6.1               np111py35_1
terminado                 0.6                      py35_0
tk                        8.5.18                        0
tornado                   4.4.2                    py35_0
traitlets                 4.3.1                    py35_0
tzlocal                   1.3                      py35_0    qiime2
wcwidth                   0.1.7                    py35_0
wheel                     0.29.0                   py35_0
whichcraft                0.4.0                    py35_0    qiime2
widgetsnbextension        1.2.6                    py35_0
xz                        5.2.2                         0
yaml                      0.1.6                         0
zeromq                    4.1.5                         0
zlib                      1.2.8                         3

I don’t know how to write a qiime2 api call with python script, for there is few documents available.
I just start qime with the command line magic %%bash

Ok, no worries then, thank you for the conda list, it appears you don’t really have any R packages installed. Could you try running this:

conda install -c bioconda -c r bioconductor-dada2

(which comes from the last part of this install docs)

You will may need to re-install r-base at that particular build again like so:

conda install -c r 'r-base=3.3.1 1'

Note: we moved your posts out of this thread into this thread because they are related to this topic. The posts that were moved appear below in this thread.

Also, our FAQ document provides guidelines for using the QIIME 2 forum. Please take a few minutes to review that document. These guidelines help us to make this forum as useful and user-friendly as possible while minimizing the time that we need to spend moderating the forum (which translates into more time that we can spend improving QIIME 2).

@yech1990, it looks like you don’t have QIIME 2 fully installed, because R is missing from your conda environment. Can you please try reinstalling QIIME 2 following the instructions in the install guide? That should get you everything you need to run dada2 quality control.

However, before performing dada2 quality control on your joined sequences, you should read this post. Even if dada2 successfully processes your sequence data, the results may not be scientifically valid.

I have the same problem with @yech1990 , and my r-base version (conda list) was:

r-base                    3.3.1                         5    r

After I re-installed r-base of the 3.3.1 1 by:

conda install -c r 'r-base=3.3.1 1'

Eeverything is fine.

1 Like

@jairideout @Yujun
I have tried conda install -c r 'r-base=3.3.1 1', but the error still exist.

I use the script below to install qiime2

conda create -n qiime2 -c qiime2 python=3.5 qiime q2cli
source activate qiime2
conda install matplotlib==1.5.1
conda install -c qiime2 q2-types q2-feature-table
conda install -c qiime2 -c conda-forge q2-diversity q2-emperor
conda install -c bioconda -c r bioconductor-dada2 mafft
conda install -c biocore fasttree
conda install -c qiime2 q2-demux q2-alignment q2-phylogeny q2-dada2 q2-composition q2-taxa q2-feature-classifier

I seems that I found the solution.

It may be caused by version conflict between libs in conda and system of Ubuntu 16.04.
To solve this problem, gawk should be installed before dada2.

conda install -n qiime2 gawk

than run R in conda env,
install dada2 from bioconductor.

1 Like

Great, thanks for following up with your solution @yech1990!