Error in QIIIME2R installation

Hi everyone,
Previously I installed the qiiime2R package in Rstudio successfully and analyzed my data with it. Suddenly, it is not working and I tried to install the package again. But it is showing me the following message. I would like to know what will be my next step. Looking forward to hearing from you. thank you.
I used this command:
if (!requireNamespace("devtools", quietly = TRUE)){install.packages("devtools")}
I am getting this one:
Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) :
namespace β€˜cli’ 3.6.0 is already loaded, but >= 3.6.1 is required

My Rstudio doesn't have the cli 3.6.1 version.

Hi @ssanjee,

I would try updating your version of cli to see if that resolves the issue. You can use the update_packages() method within the devtools package to do this:


Cheers :lizard:

tried but still not working

Followed your instructions in a different way and it worked. thank you very much

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.