Error in qiime2R tutorial

I was trying to do the qiime2R tutorial for integrating the qiime2 with R as I need to do that for my own data sets. I used the same code exactly from the tutorial but I am getting the following error:

if (!requireNamespace("devtools", quietly = TRUE)){install.packages("devtools")}
devtools::install_github("jbisanz/qiime2R")
Downloading GitHub repo jbisanz/qiime2R@HEAD
These packages have more recent versions available.
It is recommended to update all of them.

Which would you like to update?

1: All
2: CRAN packages only
3: None
4: cli (3.6.0 -> 3.6.1 ) [CRAN]
5: xfun (0.38 -> 0.39 ) [CRAN]
6: fs (1.6.1 -> 1.6.3 ) [CRAN]
7: fastmap (1.1.0 -> 1.1.1 ) [CRAN]
8: digest (0.6.31 -> 0.6.33 ) [CRAN]
9: cachem (1.0.6 -> 1.0.8 ) [CRAN]
10: htmltools (0.5.4 -> 0.5.5 ) [CRAN]
11: Rcpp (1.0.10 -> 1.0.11 ) [CRAN]
12: later (1.3.0 -> 1.3.1 ) [CRAN]
13: igraph (1.5.0 -> 1.5.0.1) [CRAN]

Enter one or more numbers, or an empty line to skip updates:
── R CMD build ──────────────────────────────────────────────────────
:heavy_check_mark: checking for file 'C:\Users\ekram\AppData\Local\Temp\RtmpWml5st\remotes36bc6e8e7f5b\jbisanz-qiime2R-2a3cee1/DESCRIPTION' (459ms)
─ preparing 'qiime2R': (5.8s)
:heavy_check_mark: checking DESCRIPTION meta-information ...
─ checking for LF line-endings in source and make files and shell scripts
─ checking for empty or unneeded directories
Omitted 'LazyData' from DESCRIPTION
─ building 'qiime2R_0.99.6.tar.gz'

Installing package into ‘C:/Users/ekram/AppData/Local/R/win-library/4.2’
(as ‘lib’ is unspecified)

  • installing source package 'qiime2R' ...
    ** using staged installation
    ** R
    ** inst
    ** byte-compile and prepare package for lazy loading
    Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) :
    namespace 'xfun' 0.38 is being loaded, but >= 0.39 is required
    Calls: ... namespaceImportFrom -> asNamespace -> loadNamespace
    Execution halted
    ERROR: lazy loading failed for package 'qiime2R'
  • removing 'C:/Users/ekram/AppData/Local/R/win-library/4.2/qiime2R'
    Warning message:
    In i.p(...) :
    installation of package ‘C:/Users/ekram/AppData/Local/Temp/RtmpWml5st/file36bc58aad1d/qiime2R_0.99.6.tar.gz’ had non-zero exit status

I have updated my R and R studio. Seeking your suggestions and opinions in this regard. Thank you.

Hello @ssanjee,

When you were prompted with

Enter one or more numbers, or an empty line to skip updates:

what did you enter?

There I select 1 and then the later lines came

Hello @ssanjee,

What does packageVersion("xfun") say?

Previously "xfun" was not installed. I installed "xfun" and again reinstalled qiime2R and it is giving me the following error:
Downloading GitHub repo jbisanz/qiime2R@HEAD
These packages have more recent versions available.
It is recommended to update all of them.
Which would you like to update?

1: All
2: CRAN packages only
3: None
4: cli (3.6.0 -> 3.6.1 ) [CRAN]
5: fs (1.6.1 -> 1.6.3 ) [CRAN]
6: fastmap (1.1.0 -> 1.1.1 ) [CRAN]
7: digest (0.6.31 -> 0.6.33 ) [CRAN]
8: cachem (1.0.6 -> 1.0.8 ) [CRAN]
9: htmltools (0.5.4 -> 0.5.5 ) [CRAN]
10: Rcpp (1.0.10 -> 1.0.11 ) [CRAN]
11: later (1.3.0 -> 1.3.1 ) [CRAN]
12: igraph (1.5.0 -> 1.5.0.1) [CRAN]

Enter one or more numbers, or an empty line to skip updates: 1
cli (3.6.0 -> 3.6.1 ) [CRAN]
fs (1.6.1 -> 1.6.3 ) [CRAN]
fastmap (1.1.0 -> 1.1.1 ) [CRAN]
digest (0.6.31 -> 0.6.33 ) [CRAN]
cachem (1.0.6 -> 1.0.8 ) [CRAN]
htmltools (0.5.4 -> 0.5.5 ) [CRAN]
Rcpp (1.0.10 -> 1.0.11 ) [CRAN]
later (1.3.0 -> 1.3.1 ) [CRAN]
igraph (1.5.0 -> 1.5.0.1) [CRAN]
Installing 9 packages: cli, fs, fastmap, digest, cachem, htmltools, Rcpp, later, igraph
Installing packages into ‘C:/Users/ekram/AppData/Local/R/win-library/4.2’
(as ‘lib’ is unspecified)

There is a binary version available but the source version
is later:
binary source needs_compilation
igraph 1.5.0 1.5.0.1 TRUE

Hello @ssanjee,

I don't see an error in that output.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.