Emperor QIIME2.2018

emperor

(Ida Pantoja) #1

Good morning,

I am using QIIME2.2018.8 version at work using a Linux server and Microsoft.
Yesterday, when I tried to visualize a PCoA in https://view.qiime2.org/, it never opened. The page stayed in “EMPEROR” but never opened. I tried the examples in the tutorial and I had the same issue. When I used my personal Mac computer, I was able to see the plot.
Today, I tried again at work after rebooting the computer and the issue continues. I didn’t have this issue before. I am wondering if the problem is with Google Chrome that needs to be updated to make it compatible with Emperor or something like that.

I would appreciate any feedback on this.

Thanks!
idapantoja


No visualization of emperor plots
(Nicholas Bokulich) assigned yoshiki #2

(Adriana Paula Bernardo Cravo) #3

Hi everyone!
I’m new on Qiime2 and I’m trying to run two samples now to get used to the software, however I have some issues with the visualization of the emperor plots.

Here is what I’m trying to do:
I applied the core-metrics-phylogenetic command and was successful to save the outputs:

Saved FeatureTable[Frequency] to: core-metrics-results/rarefied_table.qza
Saved SampleData[AlphaDiversity] % Properties([‘phylogenetic’]) to: core-metrics-results/faith_pd_vector.qza
Saved SampleData[AlphaDiversity] to: core-metrics-results/observed_otus_vector.qza
Saved SampleData[AlphaDiversity] to: core-metrics-results/shannon_vector.qza
Saved SampleData[AlphaDiversity] to: core-metrics-results/evenness_vector.qza
Saved DistanceMatrix % Properties([‘phylogenetic’]) to: core-metrics-results/unweighted_unifrac_distance_matrix.qza
Saved DistanceMatrix % Properties([‘phylogenetic’]) to: core-metrics-results/weighted_unifrac_distance_matrix.qza
Saved DistanceMatrix to: core-metrics-results/jaccard_distance_matrix.qza
Saved DistanceMatrix to: core-metrics-results/bray_curtis_distance_matrix.qza
Saved PCoAResults to: core-metrics-results/unweighted_unifrac_pcoa_results.qza
Saved PCoAResults to: core-metrics-results/weighted_unifrac_pcoa_results.qza
Saved PCoAResults to: core-metrics-results/jaccard_pcoa_results.qza
Saved PCoAResults to: core-metrics-results/bray_curtis_pcoa_results.qza
Saved Visualization to: core-metrics-results/unweighted_unifrac_emperor.qzv
Saved Visualization to: core-metrics-results/weighted_unifrac_emperor.qzv
Saved Visualization to: core-metrics-results/jaccard_emperor.qzv
Saved Visualization to: core-metrics-results/bray_curtis_emperor.qzv

However, when I try to visualize the emperor plots, I don’t get anything, only the emperor logo (see attached picture, please). I already tried to visualize with qiime tools view , https://view.qiime2.org/ and on google chrome and moziila. I’m using a VM, qiime2 2018.8, also I don’t have problems with https://get.webgl.org/, so I don’t know what could be the reason…
Could someone help me with this?
Thanks in advance!


(Nicholas Bokulich) #4

@idapantoja @Cravo_Adri, sounds like you both have the same issue so I merged them. Your topic has been assigned to a moderator to respond. Until then, I recommend hunting around on the forum, I recall others reporting a similar issue. (sorry, we are doing a workshop this week so are understaffed and cannot respond immediately)


(Yoshiki Vázquez Baeza) #5

@idapantoja would you mind sharing one of your visualizations with me. I would like to check and see if there are any silent runtime errors.


(Yoshiki Vázquez Baeza) #6

@Cravo_Adri, this is likely a bug in Emperor when comparing 2 samples. I’ve opened a ticket in our GitHub repository:


(Nicholas Bokulich) unassigned yoshiki #7

(Adriana Paula Bernardo Cravo) #8

@yoshiki and @Nicholas_Bokulich thanks for your feedback! I’ll continue looking for hints in the forum while the topic is being analyzed by the moderator :slight_smile:


(Ida Pantoja) #9

Hi Yoshiki,
Thanks for your response. What is the best way to share the doc with you?
idapantoja


(Nicholas Bokulich) assigned yoshiki #10

(Yoshiki Vázquez Baeza) #11

Through the forum (uploading it as an attachment) or a link through dropbox via a direct message on the forum.


(Nicholas Bokulich) unassigned yoshiki #12

(Ida Pantoja) #13

Hi Yoshiki,
Here 2 docs. One was generated on August using QIIME2.2017.9 and it worked previously and the other was generated last week using 2018.8. I tried the one from December in my personal computer (Mac) and it didn’t open either. In my Mac I can open the tutorial docs but at work using Microsoft, none of them open.

Thanks for your help.
idapantoja

bray_curtis_emperor_DECEMBER.qzv (768.2 KB)
bray-curtis-emperor_resistant_starch_AUGUST.qzv (725.9 KB)


(Yoshiki Vázquez Baeza) #14

Hi @idapantoja,

I just tried opening both visualizations and I was able to see a working visualization. As you pointed out before it might be the version of Google Chrome that you are using, have you tried updating it?

Alternatively can you:
1.- Go to view.qiime2.org using Google Chrome.
2.- Load one of the visualizations that are failing to open.
3.- Go to View > Developer > JavaScript Console.

A new pane should open in your current window with some text. Can you copy/paste the text and post it to this thread?


(Ida Pantoja) #15

I can’t update Chrome by myself due to Government restrictions. I have to request it. Thats why I wanted to know if that is the issue to have a reason to request the new version.

This? Attached a pic from where I copied and paste:

Active resource loading counts reached a per-frame limit while the tab was in background. Network requests will be delayed until a previous loading finishes, or the tab is brought to the foreground. See https://www.chromestatus.com/feature/5527160148197376 for more details
three.min.js:817 THREE.Curve.create() has been deprecated
three.min.js:172 THREE.WebGLRenderer 87
three.min.js:176 THREE.WebGLRenderer: Error creating WebGL context.
Yd @ three.min.js:176
require-2.1.22.min.js:19 TypeError: Cannot read property ‘getExtension’ of null
at Object.get (three.min.js:143)
at b (three.min.js:152)
at new Yd (three.min.js:176)
at new EmperorController (controller.js:141)
at init (emperor.html:163)
at HTMLDocument. (emperor.html:175)
at j (jquery-2.1.4.min.js:2)
at Object.add [as done] (jquery-2.1.4.min.js:2)
at n.fn.init.n.fn.ready (jquery-2.1.4.min.js:2)
at new n.fn.init (jquery-2.1.4.min.js:2)
check @ require-2.1.22.min.js:19
4emperor.html:171 Uncaught TypeError: Cannot read property ‘resize’ of undefined
at emperor.html:171
at dispatch (jquery-2.1.4.min.js:3)
at b.dispatch (jquery.event.drag-2.2.min.js:6)
at r.handle (jquery-2.1.4.min.js:3)


(Yoshiki Vázquez Baeza) #16

Thanks for the information. It looks like it is a problem with your browser. Some of the technologies used to display these graphics (namely WebGL and a few other web standards) change all the time, so keeping an up-to-date browser is important.

Just as one final exercise, are you able to see this a rotating cube here:
https://get.webgl.org


(Ida Pantoja) #17

No. This is what I got:

Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.

For more help, please click this link.

Check out some of the following links to learn more about WebGL and to find more web applications using WebGL.

WebGL Wiki

Want more information about WebGL?

khronos.org/webgl


(Yoshiki Vázquez Baeza) #18

Sounds like it might be your browser then. Can you try typing “chrome://flags/” into the address bar, then search for “Disable WebGL”. Disable this option if you haven’t already. If you follow these steps and still don’t see an image, go to “chrome://flags/” and then search for “Override software rendering list” and enable this option.


(Ida Pantoja) #19

Hi Yoshiki,

WebGL was already Disabled. I enabled Override software rendering list and still don’t see the image. As a side note, I can see the cube using Internet Explorer. What do you recommend to do?

Thank you!
idapantoja


(Yoshiki Vázquez Baeza) #20

Hi @idapantoja,

If those workarounds didn’t work for your computer using Google Chrome, then I don’t think I have a good way to get this working for you. Perhaps one alternative would be to reach out to your system administrators and ask them for an updated version of Google Chrome or Firefox.

Lastly, although I haven’t done any testing using Internet Explorer, it would be worth a shot to try to open view.qiime2.org there.