Demux summarize: TypeError: len() of unsized object

Hello,
I have an error message when I was running qiime demux summarize, below is the debug info:

Traceback (most recent call last):
File “/Users/wangj50/miniconda2/envs/qiime2-2017.6/lib/python3.5/site-packages/q2cli/commands.py”, line 222, in call
results = action(**arguments)
File “”, line 2, in summarize
File “/Users/wangj50/miniconda2/envs/qiime2-2017.6/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 203, in callable_wrapper
output_types, provenance)
File “/Users/wangj50/miniconda2/envs/qiime2-2017.6/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 363, in callable_executor
ret_val = callable(output_dir=temp_dir, **view_args)
File “/Users/wangj50/miniconda2/envs/qiime2-2017.6/lib/python3.5/site-packages/q2_demux/_summarize/_visualizer.py”, line 158, in summarize
ax = sns.distplot(result, kde=False)
File “/Users/wangj50/miniconda2/envs/qiime2-2017.6/lib/python3.5/site-packages/seaborn/distributions.py”, line 209, in distplot
bins = min(_freedman_diaconis_bins(a), 50)
File “/Users/wangj50/miniconda2/envs/qiime2-2017.6/lib/python3.5/site-packages/seaborn/distributions.py”, line 30, in _freedman_diaconis_bins
h = 2 * iqr(a) / (len(a) ** (1 / 3))
TypeError: len() of unsized object

This seems to be the same problem as this post. But my input have two samples instead of one and the issue should already be solved.

Then I saw this issue with underscore in sequence file name. Is it possible that because my samples have underscores in file name, so qiime2 recoganized them as 1 sample. But if that is the case, it still goes back to the ealier issue which I thought have been solved. I am running qiime2-2017.6.
Thanks!

I changed the sample ID to avoid underscores and problem solved. I wish this is written in some help doc. Thanks!

Hi @wangj50 — we generally don’t write up user documents detailing workaround for bugs, we would rather see those bugs fixed up! As a general note, our issue trackers are where we track the status of bugs. Fortunately for you, the issue that was linked to in the post you referenced above has been fixed, and should be available in the next release of QIIME 2 (2017.7). This bug fix removes the need to strip all underscores from sample IDs. Thanks!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.