Demultiplexing Paired end sequences dual index

Hi to all!..

I'm kinda new in Qiime2, and I'm trying to do the demultiplexing of some MiSeq Illumina 16S sequences. I have 4 Files:

  1. Forward_Sequences
  2. Reverse_Sequences
  3. Forward_Barcodes
  4. Reverse_Barcodes
    All the files are now in fastq.gz extension. I've been trying to use "Qiime demux emp-paired" but this plugin only has one parameter for 1 column of barcodes "--m-barcodes-column" so I cannot use both indexes.
    I tried to concatenate the barcodes files in one and create the metadata to use that single file with the "Qiime demux emp-paired" but I have the problem that only read one column of the metadata.

Also I tried to demultiplex the sequences using "cutadapt" because it considers the 2 barcodes, but I have problems creating the .qza file, because I tried to use the 4 files that I have to create the .qza using the type "--type MultiplexedPairedEndBarcodeInSequence" but the importing tool says that the files are unrecognized.

What can I do? someone has demultiplexed paired en sequences with dual indexes ? or could help me with my problem?


Welcome to the forum!
While dual indexing itself is already supported in QIIME 2, the specific format in which you have - with separate forward and reverse barcode files- is not supported. There is an on open issue for this request here, though I'm not sure when and if this will be implemented. I had a similar dataset a while back that I was able to import into QIIME 2 but had to first modify it using QIIME 1's Essentially just combining those 2 files first. See this thread for some more details.
Hope this helps!

Hi @Mehrbod_Estaki
Thank you for your welcome and help on this thing!
I did all the steps, 1st concatenate the barcodes with using QIIME 1. Then import the barcode file to QIIME 2 using the qiime tools import, creating the .qza file.
Everything good until that, but then I tried to run the demux using demux emp-paired and I got an error saying "Golay decoding requires 12nt barcodes. The barcode attempting to be decoded (GTAAGTAGGGACTCCT) is of length 16nt.
Since my barcodes are 8nt length, when are concatenated create a barcode of 16nt. I understand that, but seems that QIIME2 cannot handle it. What can I do?

Glad you're making progress! It's been a while since I've had to do something like this and the last time I did (as per that post), Golay decoding wasn't even the default in demux emp-paired. So I think all you need to do is turn off the Golay correction with the --p-no-golay-error-correction parameter because your barcodes are not Golay anyways.
By the way, I think in order for this method to work with demux emp-paired, you'll want to make sure your new concatenated barcodes are properly represented in your metadata file, meaning you'll need to concatenate your Forward and Reverse barcodes in a new column as well so they match. I realize I didn't point this out in that original post, but I think it will be required. Hope this makes sense, keep us posted!


Thank you @Mehrbod_Estaki !!! everything perfect!

1 Like

Glad you got it working :slight_smile:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.