Debudding an error was encountered while running DADA2 in R


I have been trying to denoise the data and when I ran the following command, I got this error that I can't figure out how to debug.

Here is a screenshot of the error:

And here is the command that I ran:
% qiime dada2 denoise-single
--i-demultiplexed-seqs single-end-demux.qza
--p-trunc-len 0
--p-trunc-q 25
--o-table table.qza
--o-representative-sequences rep-seqs.qza
--o-denoising-stats denoising-stats.qza

I am putting down here all other info in case this will help define the problem

  • The data is from NCBI bioprojects and it's 16S rRNA microbiome data.
  • The machine is a Mac with a processor of 2.9 GHz Dual-Core Intel Core i7 and a memory of 2.9 GHz Dual-Core Intel Core i7
  • The R version is 4.2.2 (2022-10-31)
  • The Qiime2 version is: q2cli version 2022.8.0

Any help will be very much appreciated.


It is a known issue for Macs.
png.dylib depends on linpng and conda installation runs into the conflict with brew installation.
Check your version using:
brew versions libpng
And install the newer one using:
brew update libpng

Hope that helps.

Thank you for the explanation. However, the terminal couldn't recognise this command and giving me this error.

And when I tried to upgrade libpng, I got another error that I couldn't fix.
Any clue how to fix it?


Please, retry after brew update-reset


git -C "/usr/local/Homebrew/Library/Taps/homebrew/homebrew-core" remote set-url origin


Thank you for the response. I have tried it and the problem still exits. Here is what I got when I ran brew update-reset

And this the same error that I got while running DADA2 again

Appreciate the help!


try to reinstall libpng completely.


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.