dada2 maxMismatch

Is there a way to use the maxMismatch flag in dada2 when running in qiime2?

I noticed the default is zero mismatches, and I suspect that is why so much of my data is being lost in merging (in Qiime1 I used to set this as 20%, a quick alignment of a few reads from my current data set gives ~5% differences). My reads overlap quite a lot, and can be fairly variable in length, so being lenient with merging seems like the best option, at least theoretically. Strict length or QC trimming would risk biasing against the longer reads, and merging should allow the higher quality read to “correct” the lower quality one.


Hello Alison,

This setting is not yet available in the Qiime2 plugin, but there’s an issue open:

I agree that maxMismatch is a very powerful option and should be configured by the user. Hopefully this feature is enabled in an upcoming version of q2-dada2!

For now, you could change the python script internally, or process your data with dada directly then import back into Qiime for downstream analysis.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.