DADA2 Denoise: Different Chimera parameters same output

My query isn’t really an error but I attempted to run my demux file for denoise

qiime dada2 denoise-paired
–i-demultiplexed-seqs RBD_AB_MBRS_demux.qza
–p-trim-left-f 0
–p-trim-left-r 0
–p-trunc-len-f 200
–p-trunc-lec-r 200
–p-n-threads 0
–o-representative-sequences rep_seqs.qza
–o-table table.qza
–o-denoising-stats stats.qza

I tried using the default setting for --p-chimera-method (consensus), I also tried both pooled and none, but all gave me the same output table upon checking the details of the visualization file.

I attached here my demux and my three table visualizations for reference. Hoping for any feedback on what I may have done incorrect.

Thanks!

Hi @Carlmed00!

It looks like something didn’t work - can you try again?

My Bad. Here are the files.

RBD_AB_MBRS_demux.qzv (295.3 KB) RBD_AB_MBRS_table.qzv (405.6 KB) RBD_AB_MBRS_ChimNone_table.qzv (405.6 KB) RBD_AB_MBRS_ChimPool_table.qzv (405.6 KB)

I was trying to try different chimera method on the moving pictures samples, apparently it works. My guess now is that my importation may have some problems.

My script for importation is as follows

qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path metadata
--output-path demux.qza
-- input-format PairedEndFastqManifestPhred33V2
The metadata (I made it tsv so it can be uploaded) and barcode files are attached here for reference.
Sample Sequence file is also here Dropbox - File Deleted
barcodes.fastq.gz (711.2 KB) RBD_metadata.tsv (9.4 KB)

1 Like

I am unsure how to debug since I am unsure how I may have gotten the script wrong. Hoping for your reply :smiley:

Hi @Carlmed00 - @andrewsanchez is on the case - please wait to hear from him.

2 Likes

Hi, @Carlmed00!

I tried using the default setting for --p-chimera-method (consensus), I also tried both pooled and none, but all gave me the same output table upon checking the details of the visualization file.

Rather than comparing the feature tables, you might want to take a look at the denoising stats. You can compare denoising stats for different chimera methods in two steps.

  1. Use the metadata plugin to prepare your metadata for exploration. Here’s an example from the moving pictures tutorial:
qiime metadata tabulate \
  --m-input-file stats-dada2.qza \
  --o-visualization stats-dada2.qzv
  1. View the results:

qiime tools view stats-dada2.qzv

Let me know how that goes!

Cheers,
Andrew

1 Like

Thanks for your reply!

However, upon checking all stats file (I also attached it below for reference) all results are identical.

I tried using the file provided in moving pictures but all chimera method settings provided different results which led me to the idea that my importation might have something wrong in it (i attached my demux file, metadata, barcodes, and a sample sequence file in my earlier replies for reference).

Thank you very much in advance!
RBD_AB_MBRS_ChimNone_stats.qzv (1.2 MB) RBD_AB_MBRS_ChimPool_stats.qzv (1.2 MB) RBD_AB_MBRS_stats.qzv (1.2 MB) stats_ChimNone.tsv (5.4 KB) stats_ChimPool.tsv (5.4 KB) stats_ChimPool.tsv (5.4 KB) .

Hi, @Carlmed00!

Your import step seems ok. But after taking a closer look at your stats viz, I noticed everything is being lost at the merging step. When there aren’t any reads left, chimera settings won’t have much of an impact.

My recommendation is to revisit the DADA2 section of the moving pictures tutorial. The second paragraph and the bolded sentence in particular are the important bits:

The dada2 denoise-single method requires two parameters that are used in quality filtering: --p-trim-left m , which trims off the first m bases of each sequence, and --p-trunc-len n which truncates each sequence at position n . This allows the user to remove low quality regions of the sequences. To determine what values to pass for these two parameters, you should review the Interactive Quality Plot tab in the demux.qzv file that was generated by qiime demux summarize above.

I’m not sure where you got your trimming/truncation values that you shared in your original post, but I recommend viewing the results of qiime demux summarize and reconsidering the values for trimming/truncation.

Some other questions to consider:

  • How long is the region you sequenced?
    • Keep this in mind when viewing your summary of the demultiplexing results
  • Maybe you can use just the forward reads?
    • This would make the merging step unnecessary

If you use just the forward reads, it’s not necessary to re-import. You can just pass your demux artifact into denoise-single, which will ignore reverse reads.

I hope this helps!

Cheers,
Andrew

3 Likes

I will be trying that out! However, should I use only forward/reverse reads, would it have any implications in my downstream analysis?

Hey! Thank you very much for responding. I am trying both your suggestions. However when you mentioned to check the demux visualization. I was comparing both what I have and the one from moving pictures and thought about the selection of trim length.Based, however to the demux file, my selection of 200 for trim length (total amplicon length is around 464) seems to pass high quality read scores and with the short length I was actually expecting to get more.

Nevertheless, I am attaching here the RBD_AB_MBRS_demux.qzv (295.3 KB) visualization file. I am quite hopeful with your second option(using forward reads only) however as I mentioned in my earlier reply, I am unsure of the possible repercussions of doing it downstream.

Just an update!

Thanks @andrewsanchez for your tips! Was definitely because of the trim during denoising.

I have some additional input about this. Just to share. I tried both contrinuing with paired ends but andjusting trim len to 250 instead of 200. I also did the same trim adjustment but using only the forward reads.

It gave me 2 different output, which I'll be sharing.
PAIRED_250_taxa_barplot.qzv (780.6 KB) SINGLE_250_taxa_barplot.qzv (522.7 KB)
Based on my initial observation, if I do only forward reads, I end up with many unclassified bacteria. One the other hand, proceeding with the paired ends gave me better OTUs present.

Thanks again!

2 Likes