classify-sklearn not working without error message

I am running Qiime2 with several sample sets with the pre-compiled Silva and Greengenes taxonomic classifiers (v2022.2). For one sample set, the Greengenes classifier is working but Silva is not. For the others sample sets, both classifiers are working. There is no difference in the command as I am running a script with a loop going through the specified classifiers. I re-downloaded the Silva classifier but that did not fix the problem. I increased the typical memory I use by 4x just in case there was some bizarre artifact in the data but it didn't seem to have any effect.

The most frustrating part is that no error message is being produced by the command even when I run with the '--verbose' tag. This also makes it hard to search through the forum for help! I've read so many questions and discussions and haven't found this particular problem and am feeling quite stuck at this point.

Are there any recommendations for how to proceed?

Thank you in advance!

Hello Kristina,

Welcome to the forums! :qiime2:

Yes, please give us all the details you have so we can look for clues. For example, what is the exact command you are running?

Post that script too!

Well, it worked now! I reduced the reads per batch and it took 5 hours but did complete. I had tried with reduced reads per batch before, so maybe something was going wrong with the node I was using on our server. Thank you though!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.