Can't import SILVA 132 .fna file into QIIME2

Hi all,

I am trying to train my own classifier on QIIME2 with the SILVA database but ran into an importing issue. I tried importing silva_132_99_16S.fna from the SILVA database into qiime and I tried the following code which I got from here

#ran this first just to make sure all letters were capitalized as recommended in other post
cat silva132_99.fna | tr ‘acgt’ ‘ACGT’ > seqs.fna

qiime tools import
–input-path seqs.fna
–output-path seqs.qza
–type SampleData[Sequences]

And I get the following error: seqs.fna is not a(n) QIIME1DemuxFormat file

I also tried adding in the --input-format QIIME1DemuxFormat with no avail.
I also tried this on the 16S only fna file from the SILVA 132 folder as well. I got the folder from here.

Any clues as to why this might be happening? I may simply resort to using your pre-trained classifier that you have. Is there any knowledge as to how much effectiveness you lose when using a pre-trained classifier versus training with your own sequences?

Thanks for the help!

The problem is that this is not sample data. Use FeatureData[Sequence] instead.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.