Seqs.fna is not a(n) QIIME1DemuxFormat file

Hello Everyone,
I tried importing the output generated from split_library in qiime1 using the command:
qiime tools import
–input-path seqs.fna
–output-path seqs.qza
–type SampleData[Sequences]

I got a message that it is not a Demuxformat file? Pls. let me know how I can solve this. Thank you very much.

Hi @Pseudomonas84,
I think the issue is that you are missing the following parameter from your command:
--source-format QIIME1DemuxFormat

Could you give that a try? Thanks!

Hello Nicholas,
I tried putting the source format QIIME1DemuxFormat, it still came back with a message that seqs.fna is not a QIIME1DemuxFormat file, is there another way to import this file to qiime2?
Thanks,
Raya

Hi @Pseudomonas84,
Thanks for attempting to specify the source format. Could you please run the following command (on the unimported data) and share the output:
head seqs.fna
tail seqs.fna

I want to inspect the first/last several lines to make sure this is not a formatting issue.

Thanks!

heads seqs.fna

KDC_1 D00420 org_bc=GAGATGAC new_bc=GAGATGAC bc_diffs=0
TACAGAGGGTGCAAGCGTTAATCGGAATTACTGGGCGTAAAGCgcgcgTAGGTGGTTTGTTAAGTTGGATGTGAAATCCCCGGGCTCAACCTGGGAACTGCATTCAAAACTGACTGACTAGAGTGTGGTAGAGGGTGGTGGAATTTCCTGTGTAGCGGTGAAATGCGTAGATATAGGAAGGAACACCAGTGGCGAAGGCGACCACCTGGACCAACACTGACACTGAGGTGCGAAAGCGTGGGGAGCAAACAGGATTAGATACCcc
KDC_10000 D00420 org_bc=GAGATGAC new_bc=GAGATGAC bc_diffs=0
TACAGAGGATGCAAGCGTTATCCGGAATGATTGGGCGTAAAGCGTCTGTAGGTGGCTTtttAAGTCCGCCGTCAAATCCCAGGGCTCAACTCTGGACAGGCGGTGGAAACTACCAAGCTGGAGTACGGTAGGGGCAGAGGGAATTTCCGGTGGAGCGGTGAAATGCGTAGAGATCGGAAAGAACACCAACGGCGAAAGCACTCTGCTGGGCCGACACTGACACTGAgagaCGAAAGCTAGGGGAGCGAATGGGATTAGATACCCG
KDC_10002 D00420 org_bc=GAGATGAC new_bc=GAGATGAC bc_diffs=0
TACGGAGGGTGCAAGCGTTAATCGGAATTACTGGGCGTAAAGCGCACGCAGGCGGTCTGTTAAGTCAGATGTGAAATCCCCGGGCTCAACCTGGGAACTGCATTCAAAACTGACTGACTAGAGTGTGGTAGAGGGTGGTGGAATTTCCTGTGTAGCGGTGAAATGCGTAGATATAGGAAGGAACACCAGTGGCGAAGGCGACCACCTGGACCAACACTGACACTGAGGTGCGAAAGCGTGGGGAGCAAACAGGATTAGATACCCG
KDC_10012 D00420 org_bc=GAGATGAC new_bc=GAGATGAC bc_diffs=0
TACGGAGGGTGCAAGCGTTAATCGGAATTACTGGGCGTAAAGCGCACGCAGGCGGTCTGTTAAGTCAGATGTGAAATCCCCGGGCTTAACCTGGGAACTGCATTTGAAACTGGCAGGCTTGAGTCTTGTAGAGGggggTAGAATTCCAGGTGTAGCGGTGAAATGCGTAGAGATCTGGAGGAATACCGGTGGCGAAGGCGGCCcccTGGACAAAGACTGACGCTCAGGTGCGAAAGCGTGGGGAGCAAACAGGATTAGATACCCG
KDC_1002 D00420 org_bc=GAGATGAC new_bc=GAGATGAC bc_diffs=0
TACGGAGGGTGCAAGCGTTAATCGGAATTACTGGGCGTAAAGCGCACGCAGGCGGTCTGTTAAGTCAGATGTGAAATCCCCGGGCTTAACCTGGGAACTGCATTTGAAACTGGCAGGCTTGAGTCTTGTAGAGGggggTAGAATTCCAGGTGTAGCGGTGAAATGCGTAGAGATCTGGAGGAATACCGGTGGCGAAGGCGGCCcccTGGACAAAGACTGACGCTCAGGTGCGAAAGCGTGGGGAGCAAACAGGATTAGATACCCG

tail seqs.fna

OY_9976 D00420 org_bc=GAGATCAG new_bc=GAGATCAG bc_diffs=0
TACGGAGGGAGCTAGCGTTGTTCGGAATTACTGGGCGTAAAGCGCACGTAGGCGGCTTTGTAAGTTAGAGGTGAAAGCCTGGAGCTCAACTCCAGAATTGCCTTTAAGACTGCATCGCTTGAATCCAGGAGAGGTGAGTGGAATTCCGAGTGTAGAGGTGAAATTCGTAGATATTCGGAAGAACACCAGTGGCGAAGGCGGCTCACTGGACTGGTATTGACGCTGAGGTGCGAAAGCGTGGGGAGCAAACAGGATTAGATACCCG
OY_9983 D00420 org_bc=GAGATCAG new_bc=GAGATCAG bc_diffs=0
TACGTAGGTGGCAAGCGTTGTCCGGAATTATTGGGCGTAAAGCgcgcgcAGGCGGCTTCTTAAGTCCATCTTAAAAGTGCGGGGCTTAACCCCGTGATGGGATGGAAACTGAGAGGCTGGAGTATCGGAGAGGAAAGTGGAATTCCTAGTGTAGCGGTGAAATGCGTAGAGATTAGGAAGAACACCGGTGGCGAAGGCGACTTTCTGGACGACAACTGACGCTGAGGCGCGAAAGCGTGGGGAGCAAACAGGATTAGATACCCGT
OY_9987 D00420 org_bc=GAGATCAG new_bc=GAGATCAG bc_diffs=0
TACAGAGGATGCAAGCGTTATCCGGAATGATTGGGCGTAAAGCGTCTGTAGGTGGCTTtttAAGTCCGCCGTCAAATCCCAGGGCTCAACTCTGGACAGGCGGTGGAAACTACCAAGCTGGAGTACGGTAGGGGCAGAGGGAATTTCCGGTGGAGCGGTGAAATGCGTAGAGATCGGAAAGAACACCAACGGCGAAAGCACTCTGCTGGGCCGACACTGACACTGAgagaCGAAAGCTAGGGGAGCGAATGGGATTAGATACCCG
OY_9989 D00420 org_bc=GAGATCAG new_bc=GAGATCAG bc_diffs=0
TACGTAGGTGGCAAGCGTTATCCGGAATTATTGGGCGTAAAGCgcgcgcAGGCGGTTTCTTAAGTCTGATGTGAAAGCCCACGGCTCAACCGTGGAGGGTCATTGGAAACTGGGGAACTTGAGTGCAGAAGAGAAAAGCGGAATTCCACGTGTAGCGGTGAAATGCGTAGAGATGTGGAGGAACACCAGTGGCGAAGGCGGCTTtttGGTCTGTAACTGACGCTGAGGCGCGAAAGCGTGGGGAGCAAACAGGATTAGATACCCG
OY_999 D00420 org_bc=GAGATCAG new_bc=GAGATCAG bc_diffs=0
TACAGAGGATGCAAGCGTTATCCGGAATGATTGGGCGTAAAGCGTCTGTAGGTGGCTTtttAAGTCCGCCGTCAAATCCCAGGGCTCAACTCTGGACAGGCGGTGGAAACTACCAAGCTGGAGTACGGTAGGGGCAGAGGGAATTTCCGGTGGAGCGGTGAAATGCGTAGAGATCGGAAAGAACACCAACGGCGAAAGCACTCTGCTGGGCCGACACTGACACTGAgagaCGAAAGCTAGGGGAGCGAATGGGATTAGATACCCG

Thanks a lot!

hm… those certainly look like the correct format but I do notice a bunch of lowercase characters, which might be causing this import issue.

what version of QIIME2 are you using?

Could you try the following?

cat seqs.fna | tr 'acgt' 'ACGT' > new_seqs.fna

qiime tools import \
    –input-path new_seqs.fna \
    –output-path seqs.qza \
    –type SampleData[Sequences]

It is a bit of a shot in the dark — but I can tell you that lowercase nucleotide characters can cause issues with some plugins downstream.

Another possibility is if there are duplicate sequence IDs. That should not occur, but might if you did anything unusual with the qiime1 outputs prior to trying to import (e.g., concatenating multiple seqs.fna files?). I can’t really give support on qiime1 commands, but it could help to give some context on the qiime1 commands that you used upstream to generate these files.

Please let me know if that works!

3 Likes

Hello Nicholas,
The above suggestion worked. Thank you very much.

I went back to moving pictures tutorial to try to do taxonomy barplot, so I had to use the feature classifier first, I got a plugin error:
qiime feature-classifier classify-sklearn \

–i-classifier gg-13-8-99-515-806-nb-classifier.qza
–i-reads rep-seqs.qza
–o-classification taxonomy.qza
Plugin error from feature-classifier

What could be the reason for this?

Thanks a lot

Hi @Pseudomonas84, can you please copy and paste the full error message output when you run the command with the --verbose flag?

Hi Matthew,
Thanks for the reply. I made this input and got the error message below.
qiime feature-classifier classify-sklearn --i-classifier gg-13-8-99-515-806-nb-classifier.qza --i-reads rep-seqs.qza --o-classification taxonomy.qza
Plugin error from feature-classifier:

Debug info has been saved to /tmp/qiime2-q2cli-err-r8vn3hyh.log

Thank you very much!

Hi @Pseudomonas84, can you please copy and paste the full error message output when you run the command with the --verbose flag? For example:

$ qiime feature-classifier classify-sklearn \
  --i-classifier gg-13-8-99-515-806-nb-classifier.qza \
  --i-reads rep-seqs.qza \
  --o-classification taxonomy.qza \
  --verbose

Thanks!

Hello Matthew,
My VM crashed and I had to restart it and input the command again, and it worked, no errors…weird.
Thanks a lot!

1 Like

3 off-topic replies have been split into a new topic: Troubles importing FASTA file

Please keep replies on-topic in the future.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.