Cannot read biom file and feature detail

Hello, I am having problem with reading feature-table.biom from qiime export.

When I convert it into qzv file there is an error with the feature detail page.

THe one thing for notice is that I used 19000 SE 16S rRNA v4 region file for 100nt. Is it the problem for too much data?

And the error for biom file in R is:
Error in read_biom(biom_file = BIOMfilename) :
Both attempts to read input file:
either as JSON (BIOM-v1) or HDF5 (BIOM-v2).
Check file path, file name, file itself, then try again.

I cannot even convert biom file to tsp file using biom in python due to utf-8 error.
Please anyone help me and thanks in advance.

Hello @Jilim97,

Can you post the command/code that led to that error?

biom_file = "/Users/jihwanlim/Desktop/exported_data/feature-table.biom"
biom_otu_tax <- import_biom(biom_file)

This is R code that I used.

biom_otu_tax <- read_biom(biom_file) I also tried this but same error.

Hello @Jilim97,

In your first post you wrote:

Both attempts to read input file:

In your second post you wrote:

biom_file = "/Users/jihwanlim/Desktop/exported_data/feature-table.biom"

Note the different paths and the hyphen present in the second one but missing in the first. Is it possible that you misspelled the file or got the file path wrong?


That two files are different files, I re-made a file to check my pipeline has a problem.

There is no mis spelled, so I guess I need to check my QIIME2 again,, right? maybe some information is gone

  • I modified the file name by removing hyphen and didn't work

Hello @Jilim97,

Ah okay. I unfortunately don't have any experience with the phyloseq package (which is where the import_biom function is coming from it looks like). Maybe you could open an issue on their GitHub page?

Yes, I agree.

By the way, thank you for your reply:)

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.